Составить программу, используя оператор REPEAT. Вводятся числа до тех пор пока не введется 0.
Определить, сколько среди них положительных (включая 0) и сколько отрицательных. (Числа вводятся в одну переменную в цикле).Ответы на вопрос
Program M;
var i : integer = 0;
pologitelnie : integer = 0;
otricatelnie : integer = 0; a : array[0..100] of Integer;
begin
repeat
begin
read (a[i]);
if (a[i]>=0) then
pologitelnie := pologitelnie + 1
else
otricatelnie := otricatelnie + 1;
i := i + 1;
end;
until a[i-1] = 0;
writeln('положительных: ', pologitelnie);
writeln('отрицательных: ', otricatelnie);
end.
Для решения данной задачи вам необходимо использовать цикл с оператором REPEAT для ввода чисел до тех пор, пока не будет введено число 0. В процессе ввода чисел, вы можете подсчитывать количество положительных (включая 0) и отрицательных чисел.
Вот пример программы на языке программирования Pascal, использующей оператор REPEAT, чтобы решить эту задачу:
pascalprogram CountPositiveAndNegativeNumbers; var num, positiveCount, negativeCount: Integer; begin positiveCount := 0; negativeCount := 0; repeat WriteLn('Введите число (для завершения введите 0): '); ReadLn(num); if num > 0 then positiveCount := positiveCount + 1 else if num < 0 then negativeCount := negativeCount + 1; until num = 0; WriteLn('Количество положительных чисел (включая 0): ', positiveCount); WriteLn('Количество отрицательных чисел: ', negativeCount); end.
В этой программе переменные positiveCount и negativeCount инициализируются нулевыми значениями перед циклом. В цикле мы запрашиваем у пользователя ввод числа и проверяем, является ли оно положительным, отрицательным или равным нулю, и соответственно увеличиваем счетчики. Цикл повторяется до тех пор, пока не будет введено число 0, после чего программа выводит количество положительных и отрицательных чисел, которые были введены.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
