Вопрос задан 29.07.2023 в 17:49.
Предмет Информатика.
Спрашивает Мисюрина Даша.
1)Напишите программу, которая выводит на экран имя вашего любимого киногероя. 2)В алгоритме,
записанном ниже, используются целочисленные переменные k и m. Определите значение переменной m после исполнения данного алгоритма. k:=3 m:=k+1 k:=m*m+5 k:= k-10 Зарани спасибо.Ответы на вопрос
Отвечает Соснина Софья.
1.
var
Hero:string;
begin
writeln('Введите имя вашего любимого киногероя: ');
readln(Hero);
writeln('Ваш любимый киногерой: ', Hero, '!');
end.
2.
k:=3; m:=k+1; → m:=3+1; // m = 4;
k:=m*m+5; → k:= 4*4+5; //k = 21;
k:= k-10; → k:= 21-10; // k = 11;
Нам надо было найти значение, хранящееся в переменной m: m = 4.
var
Hero:string;
begin
writeln('Введите имя вашего любимого киногероя: ');
readln(Hero);
writeln('Ваш любимый киногерой: ', Hero, '!');
end.
2.
k:=3; m:=k+1; → m:=3+1; // m = 4;
k:=m*m+5; → k:= 4*4+5; //k = 21;
k:= k-10; → k:= 21-10; // k = 11;
Нам надо было найти значение, хранящееся в переменной m: m = 4.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечное значение переменной m можно вычислить, последовательно выполняя каждое присваивание из алгоритма.
Дано:
gok := 3
m := k + 1
k := m * m + 5
k := k - 10
Шаг 1: k := 3
Теперь k равно 3.
Шаг 2: m := k + 1
Теперь m равно k + 1, что равно 3 + 1 = 4.
Шаг 3: k := m * m + 5
Теперь k равно m * m + 5, что равно 4 * 4 + 5 = 21.
Шаг 4: k := k - 10
Теперь k равно k - 10, что равно 21 - 10 = 11.
Таким образом, после исполнения данного алгоритма значение переменной m остается равным 4.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
