Вопрос задан 29.07.2023 в 12:54.
Предмет Информатика.
Спрашивает Курочкин Иван.
Написать программу на языке Pascal (цикл for и while ). Найти сумму нечетных чисел в промежутке от
20 до nОтветы на вопрос
Отвечает Смирнов Евгений.
Program l;
var
i, n, s: integer;
begin
writeln('Введите n');
readln(n);
for i = 20 to n do begin
if (i mod 2 <> 0) then
s := s + i;
end;
write(s);
end.
Отвечает Марьина Яна.
Var
i,n,s:integer;
begin
Write('n=');
Readln(n);
s:=0;
for i:=20 to n do
if Odd(i) then s:=s+i;
Writeln('Сумма с for = ',s);
s:=0; i:=21;
while i<=n do
begin
s:=s+i;
i:=i+2
end;
Writeln('Сумма с while = ',s)
end.
i,n,s:integer;
begin
Write('n=');
Readln(n);
s:=0;
for i:=20 to n do
if Odd(i) then s:=s+i;
Writeln('Сумма с for = ',s);
s:=0; i:=21;
while i<=n do
begin
s:=s+i;
i:=i+2
end;
Writeln('Сумма с while = ',s)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи на языке Pascal мы можем использовать как цикл for, так и цикл while. Вот оба варианта программы:
- Цикл
for:
pascalprogram SumOfOddNumbersForLoop; var n, i, sum: integer; begin writeln('Введите значение n:'); readln(n); sum := 0; for i := 20 to n do begin if (i mod 2 <> 0) then // Проверяем, является ли число нечетным sum := sum + i; // Если число нечетное, добавляем его к сумме end; writeln('Сумма нечетных чисел от 20 до ', n, ': ', sum); end.
- Цикл
while:
pascalprogram SumOfOddNumbersWhileLoop; var n, i, sum: integer; begin writeln('Введите значение n:'); readln(n); sum := 0; i := 20; while i <= n do begin if (i mod 2 <> 0) then // Проверяем, является ли число нечетным sum := sum + i; // Если число нечетное, добавляем его к сумме Inc(i); end; writeln('Сумма нечетных чисел от 20 до ', n, ': ', sum); end.
Обе программы выполняют одно и то же действие: находят сумму всех нечетных чисел в промежутке от 20 до введенного значения n. Вы можете выбрать любой из вариантов или проверить оба.
Похожие вопросы
Информатика 80
Информатика 95
Информатика 38
Информатика 27
Информатика 38
Информатика 40
Информатика 42
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 35
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
