Вопрос задан 29.07.2023 в 09:19. Предмет Информатика. Спрашивает Пантелеева Катя.

Написать программу, которая вычисляет произведение целых чисел от 1 до n. Число n запрашивается с

клавиатуры. Pascal ABC
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Олефир Слава.
Var
  i,n:integer;
  s:real;
begin
  Write('n= ');
  Readln(n);
  s:=1;
  for i:=1 to n do s:=s*i;
  Writeln('Произведение ',s);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для вычисления произведения целых чисел от 1 до n в Pascal ABC можно воспользоваться следующим кодом:

pascal
program ProductCalculation; var n, product: integer; i: integer; begin writeln('Введите число n:'); readln(n); product := 1; for i := 1 to n do begin product := product * i; end; writeln('Произведение целых чисел от 1 до ', n, ' равно ', product); end.

Сохраните данный код в файл с расширением .pas, например, "product_calculation.pas". Затем запустите компилятор Pascal ABC, загрузите файл и выполните программу. После этого введите число n, и программа вычислит произведение целых чисел от 1 до n.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос