Вопрос задан 29.07.2023 в 06:36. Предмет Информатика. Спрашивает Харьковская Даша.

Написать программу на Pascal, либо C++ и составить блок-схему Даны натуральные числа A1,A2...

Признак конца последовательности 99. Найти количество положительных чисел и удвоенное количество отрицательных чисел.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Спиридонова Алёна.

Подключи библиотеки iostream и Windows.h


int main() {

int nNumsCount = 0,

pNumsCount;

int number = 0;

while(std::cin >> number && number != 99){

if(number < 0)

++nNumsCount;

if(number > 0)

++pNumsCount;

}

std::cout << pNumsCount << '\n' << 2*nNumsCount << std::endl;

system("pause");

return 0;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи можно написать программу на языке Pascal или C++, которая будет считывать числа из последовательности и находить количество положительных чисел и удвоенное количество отрицательных чисел. Для удобства предположим, что последовательность чисел заканчивается при вводе числа 99.

Ниже приведен пример программы на языке Pascal:

pascal
program CountPositiveAndDoubleNegative; var num, positiveCount, negativeCount: integer; begin positiveCount := 0; negativeCount := 0; repeat write('Введите число (для окончания введите 99): '); readln(num); if num = 99 then break; if num > 0 then positiveCount := positiveCount + 1 else if num < 0 then negativeCount := negativeCount + 1; until false; writeln('Количество положительных чисел: ', positiveCount); writeln('Удвоенное количество отрицательных чисел: ', negativeCount * 2); end.

Программа работает следующим образом:

  1. Инициализирует переменные positiveCount и negativeCount нулями.
  2. Запускает бесконечный цикл (repeat-until), в котором пользователю предлагается ввести число.
  3. Если число равно 99, цикл прерывается (break) и программа переходит к выводу результатов.
  4. Если число положительное, увеличивается счетчик положительных чисел (positiveCount).
  5. Если число отрицательное, увеличивается счетчик отрицательных чисел (negativeCount).
  6. После окончания ввода последовательности, программа выводит количество положительных чисел и удвоенное количество отрицательных чисел.

Теперь давайте составим блок-схему для этой программы:

Блок-схема CountPositiveAndDoubleNegative

Обратите внимание, что блок-схема может быть представлена различными способами, и приведенная здесь является лишь одним из возможных вариантов.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос