Вопрос задан 29.07.2023 в 05:21.
Предмет Информатика.
Спрашивает Алимбек Аян.
Составьте программу, которая выводит последовательность чисел 1 2 3 4 5 и 5 4 3 2 1,
используя циклwhile. И такую же программу используя цикл repeat. PascalОтветы на вопрос
Отвечает Насибов Шамиль.
Var
i: integer;
begin
i := 1;
while i <= 5 do begin
writeln (i);
i := i + 1
end;
while i >= 1 do begin
writeln (i);
i := i - 1
end;
end.
i: integer;
begin
i := 1;
while i <= 5 do begin
writeln (i);
i := i + 1
end;
while i >= 1 do begin
writeln (i);
i := i - 1
end;
end.
Отвечает Калабин Алексей.
// PascalABC.NET
// ------ Цикл While ---------
begin
var i := 1;
while i < 6 do
begin
write(i, ' ');
inc(i);
end;
writeln;
dec(i);
while i > 0 do
begin
write(i, ' ');
dec(i)
end
end.
// ------- Цикл Repeat --------
begin
var i := 1;
repeat
write(i, ' ');
inc(i);
until i>5;
writeln;
dec(i);
repeat
write(i, ' ');
dec(i)
until i<1
end.
// ------ Цикл While ---------
begin
var i := 1;
while i < 6 do
begin
write(i, ' ');
inc(i);
end;
writeln;
dec(i);
while i > 0 do
begin
write(i, ' ');
dec(i)
end
end.
// ------- Цикл Repeat --------
begin
var i := 1;
repeat
write(i, ' ');
inc(i);
until i>5;
writeln;
dec(i);
repeat
write(i, ' ');
dec(i)
until i<1
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для вывода последовательности чисел 1 2 3 4 5 и 5 4 3 2 1 с использованием циклов while и repeat на Pascal, вы можете воспользоваться следующим кодом:
- Используя цикл
while:
pascalprogram WhileLoopExample; var i: Integer; begin // Выводим последовательность 1 2 3 4 5 i := 1; while i <= 5 do begin Write(i, ' '); Inc(i); end; // Выводим последовательность 5 4 3 2 1 i := 5; while i >= 1 do begin Write(i, ' '); Dec(i); end; Readln; end.
- Используя цикл
repeat:
pascalprogram RepeatLoopExample; var i: Integer; begin // Выводим последовательность 1 2 3 4 5 i := 1; repeat Write(i, ' '); Inc(i); until i > 5; // Выводим последовательность 5 4 3 2 1 i := 5; repeat Write(i, ' '); Dec(i); until i < 1; Readln; end.
Обе программы выведут желаемые последовательности чисел с использованием соответствующих циклов.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
