Срочно! Помогите написать программу в паскале,которая бы высчитывала площадь треугольника по
формуле герона и проверяла возможность существования треугольника! Заранее спасибоОтветы на вопрос
// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018
// Внимание! Если программа не работает, обновите версию!
begin
var (a, b, c) := ReadReal3('Введите стороны треугольника через пробел:');
if (a + b > c) and (a + c > b) and (b + c > a) then
begin
var p := (a + b + c) / 2;
Println('Площадь треугольника равна',
Sqrt(p * (p - a) * (p - b) * (p - c)))
end
else Println('Треугольник с такими сторонами не существует')
end.

Конечно, помогу! Вот программа на языке Паскаль, которая вычисляет площадь треугольника по формуле Герона и проверяет возможность существования треугольника:
pascalprogram TriangleArea; var a, b, c, s, area: real; begin writeln('Введите длины сторон треугольника:'); write('a: '); readln(a); write('b: '); readln(b); write('c: '); readln(c); { Проверяем условие существования треугольника } if (a + b > c) and (a + c > b) and (b + c > a) then begin { Вычисляем полупериметр треугольника } s := (a + b + c) / 2; { Вычисляем площадь треугольника по формуле Герона } area := sqrt(s * (s - a) * (s - b) * (s - c)); writeln('Площадь треугольника: ', area:0:2); end else begin writeln('Треугольник с такими сторонами не существует.'); end; readln; end.
Программа сначала запрашивает у пользователя длины сторон треугольника (a, b, c). Затем она проверяет условие существования треугольника (сумма длин двух сторон должна быть больше длины третьей стороны). Если условие существования выполняется, то программа вычисляет полупериметр (s) треугольника и далее площадь треугольника по формуле Герона. В противном случае, если треугольник с такими сторонами невозможен, программа выводит соответствующее сообщение.
Убедитесь, что вводите корректные значения сторон треугольника для правильного вычисления.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
