 
Дано двузначное число a. Напишите программу определения: является ли сумма его цифр двузначным
числом; превышает ли сумма его цифр число X, которое вводится дополнительно; кратна ли сумма его цифр 6; больше ли цифра десятков цифры единиц; входят ли в него цифры 4 или 7; оканчивается ли число цифрой 5. c++ 0
        0
         0
        0
    Ответы на вопрос
 
        #include <iostream>
#include <string>
#include <algorithm>
#include <vector>
using namespace std;
int Accum (const vector<int>& v) { // сумма цифр числа
int sum = 0;
for (auto x : v) {
sum += x;
}
return sum;
}
vector<int> NumInNums (const int& number) { // разбираем число на цифры
vector<int> Nums = {};
int num = number;
while (num != 0) {
Nums.push_back(num % 10);
num /= 10;
}
reverse(begin(Nums), end(Nums));
return Nums;
}
void Funct_1 (const int& number_2, const vector<int> nums) {
int Accumul = Accum(nums);
if (Accumul >= 10) { // проверка суммы на двузначность
cout << "Two-digit number" << endl;
} else {
cout << "Not a two digit number" << endl;
}
if (Accumul > number_2) { // больше или меньше, чем х
cout << "Exceeds" << endl;
} else {
cout << "Not exceed" << endl;
}
if (Accumul % 6 == 0) { // кратность суммы цифр шести
cout << "Multiple 6" << endl;
} else {
cout << "Not multiple 6" << endl;
}
}
void Funct_2(const vector<int>& v) {
if (v[v.size() - 2] > v[v.size() - 1]) { // сравнение цифры десятков с цифрой единиц
cout << "The number of tens more digits units" << endl;
} else {
cout << "The number of units is greater than the number of tens" << endl;
}
bool F = false;
for (auto x : v) { // входит ли цифра 4 или 7 в число
if ((x == 4) or (x == 7)) {
F = true;
break;
}
}
if (F == true) {
cout << "4 or 7 enters" << endl;
} else {
cout << "4 or 7 is not included in the number" << endl;
}
if (v[v.size() - 1] == 5) { // оканчивается ли число цифрой 5
cout << "Ends with the number 5" << endl;
} else {
cout << "Not end in 5" << endl;
}
}
int main() {
int number_1, number_2;
vector<int> nums;
cout << "Number a: ";
cin >> number_1;
cout << "Number x: ";
cin >> number_2;
Funct_1(number_2, NumInNums(number_1));
Funct_2(NumInNums(number_1));
return 0;
}
 0
                    0
                     0
                    0
                 
            Для выполнения всех перечисленных условий, нам понадобится написать программу на языке C++. Вот пример программы, которая выполняет все указанные условия:
cpp#include <iostream>
using namespace std;
int main() {
    int a, X;
    
    // Ввод двузначного числа a
    cout << "Введите двузначное число a: ";
    cin >> a;
    
    // Ввод числа X
    cout << "Введите число X: ";
    cin >> X;
    
    // Вычисление суммы цифр двузначного числа a
    int sumOfDigits = (a % 10) + (a / 10);
    
    // Проверка является ли сумма цифр двузначным числом
    if (sumOfDigits >= 10 && sumOfDigits <= 99) {
        cout << "Сумма цифр является двузначным числом." << endl;
    } else {
        cout << "Сумма цифр НЕ является двузначным числом." << endl;
    }
    
    // Проверка превышает ли сумма цифр число X
    if (sumOfDigits > X) {
        cout << "Сумма цифр превышает число X." << endl;
    } else {
        cout << "Сумма цифр НЕ превышает число X." << endl;
    }
    
    // Проверка кратности суммы цифр числу 6
    if (sumOfDigits % 6 == 0) {
        cout << "Сумма цифр кратна 6." << endl;
    } else {
        cout << "Сумма цифр НЕ кратна 6." << endl;
    }
    
    // Проверка, больше ли цифра десятков цифры единиц
    int onesDigit = a % 10;
    int tensDigit = a / 10;
    if (tensDigit > onesDigit) {
        cout << "Цифра десятков больше цифры единиц." << endl;
    } else {
        cout << "Цифра десятков НЕ больше цифры единиц." << endl;
    }
    
    // Проверка вхождения цифр 4 или 7
    if (a % 10 == 4 || a % 10 == 7 || a / 10 == 4 || a / 10 == 7) {
        cout << "В число входит цифра 4 или 7." << endl;
    } else {
        cout << "В число НЕ входит цифра 4 или 7." << endl;
    }
    
    // Проверка оканчивается ли число цифрой 5
    if (a % 10 == 5) {
        cout << "Число оканчивается цифрой 5." << endl;
    } else {
        cout << "Число НЕ оканчивается цифрой 5." << endl;
    }
    
    return 0;
}
Программа запрашивает у пользователя двузначное число a и число X. Затем она проверяет выполнение каждого из указанных условий и выводит соответствующие сообщения.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			