Вопрос задан 27.07.2023 в 09:42.
Предмет Информатика.
Спрашивает Зубков Дмитрий.
ПОМОГИТЕ С ПАСКАЛЕМ ПОЖАЛУЙСТА Составить программу Для введённых с клавиатеры чисел каждое число
умножить на предыдущее. Вывести на печать результат вычислений. Количество чисел ограничено вторым введённым числомОтветы на вопрос
Отвечает Балабуркин Илья.
PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018
Внимание! Если программа не работает, обновите версию!
begin
Print(ReadlnInteger('1-е число:') * ReadlnInteger('2-е число:'))
end.
Отвечает Мамаев Максим.
Program pas
var a, b, c: integer;
begin
writeln('Введите первое число');
readln(a);
Writeln('Введите второе число');
readln(b);
c:= b*a;
writeln('Результат=', c);
end.
var a, b, c: integer;
begin
writeln('Введите первое число');
readln(a);
Writeln('Введите второе число');
readln(b);
c:= b*a;
writeln('Результат=', c);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, помогу! Вот программа на языке Pascal, которая решает вашу задачу:
pascalprogram MultiplyByPrevious; var num, previous, result: Integer; count: Integer; begin Write('Введите количество чисел: '); ReadLn(count); Write('Введите первое число: '); ReadLn(previous); WriteLn('Результаты умножения:'); for i := 1 to count do begin Write(previous, ' * '); ReadLn(num); result := previous * num; Write(num, ' = ', result); WriteLn; previous := num; end; end.
Программа запросит у вас количество чисел и первое число. Затем она будет последовательно запрашивать следующие числа, умножать каждое на предыдущее и выводить результаты вычислений на печать. Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь спрашивать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
