Вопрос задан 26.07.2023 в 15:11.
Предмет Информатика.
Спрашивает Поперечный Раим.
Пожалуйста решение в Turbo/Free pascal 1) Написать программу. Массив из 10 чисел заполнить с
клавиатуры. Определить сколько двузначных чисел начинаются на нечётную цифру. 2) Написать программу. Массив из 20 чисел заполнить случайными числами [-100, 100]. Найти величину максимального отклонения (модуля разности) между любыми двумя элементами массива. 3) Написать программу. Массив из 10 чисел заполнить с клавиатуры. Определить сумму чисел, начинающихся на цифру 5.Помогите пожалуйста, к утру нужны программы.Ответы на вопрос
Отвечает Демедюк Андрей.
Ваши задачи одной программой. Если нужно порознь, - "разбейте" на три сами. Там указано циферками в комментариях перед каждой задачей: //1 //2 //3


Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот решения трех задач на языке программирования Turbo/Free Pascal:
- Определить, сколько двузначных чисел начинается на нечётную цифру:
pascalprogram Task1; var arr: array[1..10] of integer; i, count: integer; begin count := 0; writeln('Введите 10 чисел:'); for i := 1 to 10 do begin readln(arr[i]); if (arr[i] >= 10) and (arr[i] <= 99) and (arr[i] mod 2 <> 0) then Inc(count); end; writeln('Количество двузначных чисел, начинающихся на нечётную цифру: ', count); end.
- Найти величину максимального отклонения (модуля разности) между любыми двумя элементами массива:
pascalprogram Task2; var arr: array[1..20] of integer; i, j, maxDeviation: integer; begin Randomize; writeln('Массив из 20 случайных чисел:'); for i := 1 to 20 do begin arr[i] := Random(201) - 100; // Заполняем массив случайными числами [-100, 100] write(arr[i], ' '); end; writeln; maxDeviation := 0; for i := 1 to 19 do begin for j := i + 1 to 20 do begin if abs(arr[i] - arr[j]) > maxDeviation then maxDeviation := abs(arr[i] - arr[j]); end; end; writeln('Величина максимального отклонения: ', maxDeviation); end.
- Определить сумму чисел, начинающихся на цифру 5:
pascalprogram Task3; var arr: array[1..10] of integer; i, sum: integer; strNum: string; begin sum := 0; writeln('Введите 10 чисел:'); for i := 1 to 10 do begin readln(arr[i]); strNum := IntToStr(arr[i]); if Length(strNum) > 0 then begin if strNum[1] = '5' then Inc(sum, arr[i]); end; end; writeln('Сумма чисел, начинающихся на цифру 5: ', sum); end.
Скопируйте соответствующий код для каждой задачи в среду программирования Turbo/Free Pascal и скомпилируйте. Эти программы решат задачи и выведут результаты на экран. Удачи с выполнением заданий!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
