 
Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит
этот возраст со словом «год», «года» или «лет». Например, «21 год», «22 года», «25 лет». Пример:Введите возраст: 18 Вам 18 лет. Пример:Введите возраст: 21Вам 21 год. Пример:Введите возраст: 22Вам 22 года.На C++ или Паскаль 0
        0
         0
        0
    Ответы на вопрос
 
        program Vozrasr;
var
AGE: integer;//Переменная возраста
begin
writeln('Введите любое число от 1 до 120');
Readln(AGE); //Ввод возраста
if (AGE < 1) or (AGE > 120) then
begin
writeln('ERROR!')
end
else
begin
case AGE of //для чисел от 11 до 20 создаем отд-ый кейс
11..20: Writeln('Ответ: Мне ', AGE, ' лет');
Else //иначе если они не входят в диапазон от [11..20], то выполняется второй кейс
begin
case AGE mod 10 of //делим на 10 и получаем остаток =
1: Writeln('Ответ: Мне ', AGE, ' год');
2..4: Writeln('Ответ: Мне ', AGE, ' года');
0, 5..9: Writeln('Ответ: Мне ', AGE, ' лет');
end;
end;
end;
end;
end.
 0
                    0
                     0
                    0
                 
            Для решения этой задачи на C++, можно использовать конструкцию if-else для проверки правильного согласования слова "год", "года" или "лет". Вот пример программы на C++:
cpp#include <iostream>
using namespace std;
int main() {
    int age;
    cout << "Введите возраст: ";
    cin >> age;
    if (age >= 11 && age <= 20) {
        cout << "Вам " << age << " лет." << endl;
    } else if (age % 10 == 1) {
        cout << "Вам " << age << " год." << endl;
    } else if (age % 10 >= 2 && age % 10 <= 4) {
        cout << "Вам " << age << " года." << endl;
    } else {
        cout << "Вам " << age << " лет." << endl;
    }
    return 0;
}
На Pascal программный код будет выглядеть так:
pascalprogram AgeInWords; var age: Integer; begin Write('Введите возраст: '); ReadLn(age); if (age >= 11) and (age <= 20) then WriteLn('Вам ', age, ' лет.') else if (age mod 10 = 1) then WriteLn('Вам ', age, ' год.') else if (age mod 10 in [2, 3, 4]) then WriteLn('Вам ', age, ' года.') else WriteLn('Вам ', age, ' лет.'); end.
Обе программы выполняют одно и то же действие: считывают возраст, а затем выводят его со словом "год", "года" или "лет" в зависимости от условий.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			