Вопрос задан 26.07.2023 в 13:53.
Предмет Информатика.
Спрашивает Курганова Диана.
Напишите программу в pascal Сергей страдает ожирением в процессе голодании он каждую неделю
скидывает 3% от предыдущего веса изначально он весил 150 кг в машину он влезет когда будет весить 96 кг Через сколько недель он влезет в машину?Ответы на вопрос
Отвечает Адамайтись Януш.
VAR
MASSA:real;
NED:INTEGER;
BEGIN
MASSA:=150;
NED:=0;
WHILE (MASSA>=96) DO
BEGIN
MASSA:=MASSA-MASSA*0.03;
NED:=NED+1;
END;
WRITELN('Через ',NED,' недель Сергей влезет в машину')
END.
Отвечает Чувашева Катя.
var v,z:real;
i:integer;
begin
v:=150;
while not(v<=96) do
begin
z:=(v/100)*3;
v:=v-z;
inc(i);
end;
write(i);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи нужно написать программу, которая будет вычислять количество недель, через которое вес Сергея станет равен или меньше 96 кг. Мы будем уменьшать его вес на 3% каждую неделю до тех пор, пока вес не достигнет или не станет меньше 96 кг.
Вот программа на языке Pascal:
pascalprogram Obesity; var weight, targetWeight: real; weeks: integer; begin weight := 150; // Изначальный вес Сергея targetWeight := 96; // Вес, при котором он влезет в машину weeks := 0; // Начальное количество недель while weight > targetWeight do begin weight := weight - (weight * 0.03); // Уменьшаем вес на 3% weeks := weeks + 1; // Увеличиваем количество недель на 1 end; writeln('Через ', weeks, ' недель(и) Сергей сможет влезть в машину.'); end.
Эта программа выведет количество недель, через которое вес Сергея станет меньше или равен 96 кг.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
