Паскаль. Дано натуральное число N. Найти и вывести все числа в интервале от 1 до N - 1, у которых
СУММА ВСЕХ ЦИФР совпадает с СУММОЙ цифр данного числа. Если таких чисел нет, то вывести слово "нет". Пример: N = 44. Числа: 17, 26, 35.Ответы на вопрос
function SumDigit(n: integer): integer;
begin
result := 0;
var s := n.ToString;
for var i := 1 to s.length do
result += s[i].ToDigit;
end;
begin
var n := ReadInteger();
var SumN := SumDigit(n);
var found := False;
for var i := 1 to n - 1 do
if SumDigit(i) = SumN then
begin
Print(i);
found := True
end;
if not found then Print('нет')
end.
Для решения этой задачи вам потребуется написать программу на языке Паскаль. Вот один из возможных способов решения этой задачи:
pascalprogram FindNumbers; function SumOfDigits(num: Integer): Integer; var digit: Integer; begin Result := 0; while num > 0 do begin digit := num mod 10; Result := Result + digit; num := num div 10; end; end; procedure FindNumbersWithEqualSum(N: Integer); var i, currentSum, sumOfDigitsI: Integer; found: Boolean; begin found := False; for i := 1 to N - 1 do begin currentSum := SumOfDigits(i); sumOfDigitsI := SumOfDigits(SumOfDigits(i)); if currentSum = sumOfDigitsI then begin Write(i, ' '); found := True; end; end; if not found then Write('нет'); end; var N: Integer; begin Write('Введите значение N: '); Readln(N); Write('Числа: '); FindNumbersWithEqualSum(N); end.
Программа состоит из двух основных частей: функции SumOfDigits, которая вычисляет сумму всех цифр числа, и процедуры FindNumbersWithEqualSum, которая находит и выводит числа с совпадающими суммами цифр.
Программа запрашивает у пользователя ввод значения N, затем вызывает процедуру FindNumbersWithEqualSum для поиска чисел и вывода результата. Если таких чисел нет, программа выведет "нет". В примере с N = 44, программа выведет "Числа: 17 26 35".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
