Написать программу на c++, где пользователь вводит своё ФИО, а программа выдаёт количество
символов, которые пользователь ввёл с клавиатурыОтветы на вопрос
        /*В комментария вы сказали, что нужно считать не все символы строки (не считать пробел), что я и отразил в коде. Если понадобится считать все символы строки, то можно обойтись без цикла, а сделать так: cout << "Symbols: " << fio.length();).*/
#include <iostream>
using namespace std;
int main()
{
string fio;
int counter = 0;
cout << "Enter FIO: ";
getline(cin, fio);
for (int i = 0; i < fio.length(); i++)
{
if (fio[i] != ' ')
counter++;
}
cout << "Symbols: " << counter;
return 0;
}


            Для написания программы на C++, которая принимает ввод ФИО от пользователя и выводит количество введенных символов, можно использовать стандартную библиотеку C++ для работы со строками. Вот пример программы:
cpp#include <iostream>
#include <string>
int main() {
    // Запрос на ввод ФИО
    std::cout << "Введите ваше ФИО: ";
    // Считываем строку с ФИО
    std::string fullName;
    std::getline(std::cin, fullName);
    // Вычисляем количество символов в строке
    int charCount = fullName.length();
    // Выводим результат
    std::cout << "Вы ввели " << charCount << " символов." << std::endl;
    return 0;
}
Программа запрашивает у пользователя ввод ФИО с помощью std::getline(), считывает введенную строку и затем использует метод length() для определения количества символов в строке. Результат выводится на экран.
Похожие вопросы
			
			
			
			
			
			
			Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			