Написать программу на ЯП Паскаль для вычисления площади треугольника по его сторонам AB, BC, CA
(формула Герона). Программу написать на 13 строк.Ответы на вопрос
//PASCAL ABC.NET
var
s, p, ab, bc, ca: real;
begin
read(ab, bc, ca);
p := (ab + bc + ca) / 2;
s := sqrt(p * (p - ab) * (p - bc) * (p - ca));
writeln(p, #10, s);
end.
Ровно 13 строк:
program Geron;
var ab,bc,ca,p: real;
begin
writeln('Определение площади треугольника по теореме Герона');
write('Введите сторону треугольника AB: ');
readln(ab);
write('Введите сторону треугольника BC: ');
readln(bc);
write('Введите сторону треугольника CA: ');
readln(ca);
p:=(ab+bc+ca)/2;
writeln('Площадь треугольника равна ',sqrt(p*(p-ab)*(p-bc)*(p-ca)):0:3)
end.
Для решения задачи с ограничением в 13 строк на Паскале, мы можем написать следующий код:
pascalprogram AreaOfTriangle; var AB, BC, CA, S: real; begin write('Введите длину стороны AB: '); readln(AB); write('Введите длину стороны BC: '); readln(BC); write('Введите длину стороны CA: '); readln(CA); S := sqrt((AB + BC + CA) * (BC + CA - AB) * (AB + CA - BC) * (AB + BC - CA)) / 4; writeln('Площадь треугольника: ', S:0:2); end.
Обратите внимание, что этот код содержит 13 строк программы (включая заголовочные строки). Однако, рекомендуется добавить комментарии к коду для его лучшего понимания и поддерживаемости.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
