Составить программу в pascal определить сколько слов в тексте ( слово - это набор
символов,разделенных пробелом )Ответы на вопрос
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018
Внимание! Если программа не работает, обновите версию!
begin
ReadlnString.ToWords.Count.Println
end.
Пример
Наша Маша громко плачет уронила в речку мячик
8
Для определения количества слов в тексте на языке Pascal, можно использовать следующую программу:
pascalprogram CountWords; uses crt; function CountWordsInText(const text: string): Integer; var i, wordCount: Integer; inWord: Boolean; begin wordCount := 0; inWord := False; for i := 1 to Length(text) do begin if text[i] = ' ' then inWord := False else if not inWord then begin inWord := True; Inc(wordCount); end; end; CountWordsInText := wordCount; end; var text: string; numWords: Integer; begin clrscr; writeln('Введите текст:'); readln(text); numWords := CountWordsInText(text); writeln('Количество слов в тексте: ', numWords); readln; end.
Эта программа определит количество слов введенного пользователем текста. Она использует функцию CountWordsInText, которая принимает текст в виде строки и возвращает количество слов в этом тексте. Функция проходит по каждому символу текста и увеличивает счетчик слов, когда обнаруживает начало нового слова (если предыдущий символ был пробелом).
Программа выводит результат на экран после того, как пользователь введет текст. Обратите внимание, что в данной программе слова разделяются только пробелами, другие разделители, такие как запятые или точки, будут восприняты как часть слова. Вы можете доработать логику функции CountWordsInText, чтобы учитывать другие разделители, если это необходимо.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
