Вопрос задан 25.07.2023 в 15:26.
Предмет Информатика.
Спрашивает Лубченков Иван.
Составить программу PASCAL. помогите пожалуйста, хелп ! Ввести с клавиатуры 7 чисел и определить:
1. Сумму чисел кратных 5 2. Сумму отрицательных чисел кратных к 3 3. Количество положительных, четных чисел кратных 7Ответы на вопрос
Отвечает Глушко Настинька.
Var
begin
for i:=1 to 7 do begin
write (A=); read (a);
end;
sk:=0;
s:=0;
c:=0;
for i:=1 to 7 do begin
if a mod 5=0 then begin
sk:=sk+a;
end;
if (a<0) and (a mod 3=0) then begin
s:=s+a;
end;
if (a>0) and (a mod 2=0) and (a mod 7=0) then begib
c:=c+1;
end;
end;
write (sk,s,c);
end.
begin
for i:=1 to 7 do begin
write (A=); read (a);
end;
sk:=0;
s:=0;
c:=0;
for i:=1 to 7 do begin
if a mod 5=0 then begin
sk:=sk+a;
end;
if (a<0) and (a mod 3=0) then begin
s:=s+a;
end;
if (a>0) and (a mod 2=0) and (a mod 7=0) then begib
c:=c+1;
end;
end;
write (sk,s,c);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу вам составить программу на языке Pascal, чтобы выполнить указанные действия. Ниже приведен код программы:
pascalprogram CalculateNumbers; var i, num, sumMultiplesOf5, sumNegativeMultiplesOf3, countPositiveEvenMultiplesOf7: integer; begin sumMultiplesOf5 := 0; sumNegativeMultiplesOf3 := 0; countPositiveEvenMultiplesOf7 := 0; writeln('Введите 7 чисел:'); for i := 1 to 7 do begin readln(num); { Проверяем кратность 5 } if num mod 5 = 0 then sumMultiplesOf5 := sumMultiplesOf5 + num; { Проверяем отрицательные числа и их кратность 3 } if (num < 0) and (num mod 3 = 0) then sumNegativeMultiplesOf3 := sumNegativeMultiplesOf3 + num; { Проверяем положительные, четные числа и их кратность 7 } if (num > 0) and (num mod 2 = 0) and (num mod 7 = 0) then countPositiveEvenMultiplesOf7 := countPositiveEvenMultiplesOf7 + 1; end; writeln('Сумма чисел, кратных 5: ', sumMultiplesOf5); writeln('Сумма отрицательных чисел, кратных 3: ', sumNegativeMultiplesOf3); writeln('Количество положительных, четных чисел, кратных 7: ', countPositiveEvenMultiplesOf7); readln; end.
Программа считывает 7 чисел с клавиатуры, а затем определяет сумму чисел, кратных 5, сумму отрицательных чисел, кратных 3, и количество положительных, четных чисел, кратных 7.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
