 
5. Дан двумерный массив целых чисел. Составить программу, которая определяет, есть ли в некотором
столбце массива хотя бы один элемент, кратный заданному числу. 0
        0
         0
        0
    Ответы на вопрос
 
        PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018
Внимание! Если программа не работает, обновите версию!
begin
var (m, n) := ReadInteger2('Количество строк и столбцов в массиве:');
Writeln('*** Исходный массив ***');
var a := MatrRandom(m, n, -99, 99);
a.Println(4);
Writeln(4 * a.ColCount * '-');
var nCol := ReadInteger('В каком столбце ищем?');
var C := ReadInteger('На кратность чему проверить?');
if a.Col(nCol - 1).Any(t -> t mod C = 0) then
Writeln('Есть такие элементы')
else Writeln('Таких элементов нет')
end.

 0
                    0
                     0
                    0
                 
            Для решения этой задачи, вам нужно будет пройтись по каждому столбцу массива и проверить, есть ли хотя бы один элемент, кратный заданному числу. Для этого вы можете использовать двойной цикл, чтобы пройтись по всем элементам массива.
Ниже представлена примерная программа на языке Python:
pythondef is_element_multiple_in_column(matrix, num):
    rows = len(matrix)
    cols = len(matrix[0])
    for j in range(cols):  # Итерация по столбцам
        for i in range(rows):  # Итерация по строкам в текущем столбце
            if matrix[i][j] % num == 0:
                return True  # Если нашли элемент, кратный num, возвращаем True
    return False  # Если не нашли ни одного такого элемента
# Пример массива для тестирования
array = [
    [1, 2, 3],
    [4, 5, 6],
    [7, 8, 9]
]
# Пример вызова функции с массивом и заданным числом
result = is_element_multiple_in_column(array, 3)
# Вывод результата
if result:
    print("В некотором столбце есть элемент, кратный заданному числу.")
else:
    print("В некотором столбце нет элементов, кратных заданному числу.")
Вы можете протестировать эту программу с различными массивами и числами, чтобы убедиться в её правильности.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			