Есть массив (int arr[10] = {5,4,6,17,2,3,16,9,8,1};). Нужно написать программу, которая меняет
все нечетные числа на 1, а четные – на 10. Вывести элементы массива в консоль;Ответы на вопрос
#include <iostream> //подключаем библиотеки
#include <fstream> //подключаем библиотеки
using namespace std; //пространство имён
int main() {
setlocale(LC_ALL, "Russian"); //русский
int arr[10] = {5,4,6,17,2,3,16,9,8,1};
for(int i = 0; i < 10; i++) //сортируем масссив
{
if (arr[i] % 2 == 0) //все четные
{
arr[i] = 1; //меняем значение
cout << arr[i] << " "; //выводим
}else //все нечетные
{
arr[i] = 10; //меняем значение
cout << arr[i] << " "; //выводим
}
}
return 0; //возращаем ничего
}
Для решения этой задачи, вам нужно пройтись по массиву и заменить каждое нечетное число на 1 и каждое четное на 10. Затем выведите измененный массив на консоль. Вот пример программы на языке C, которая выполняет эту задачу:
c#include <stdio.h>
int main() {
int arr[10] = {5, 4, 6, 17, 2, 3, 16, 9, 8, 1};
int i;
printf("Исходный массив: ");
for (i = 0; i < 10; i++) {
printf("%d ", arr[i]);
}
// Заменяем нечетные числа на 1 и четные на 10
for (i = 0; i < 10; i++) {
if (arr[i] % 2 == 0) {
arr[i] = 10; // Четное число
} else {
arr[i] = 1; // Нечетное число
}
}
printf("\nИзмененный массив: ");
for (i = 0; i < 10; i++) {
printf("%d ", arr[i]);
}
return 0;
}
Программа создает исходный массив, затем изменяет его элементы в соответствии с условием, и выводит исходный и измененный массивы на консоль.
Когда вы запустите программу, она должна вывести:
Исходный массив: 5 4 6 17 2 3 16 9 8 1 Измененный массив: 1 10 10 1 10 1 10 1 10 1
Как видно из вывода, нечетные числа заменены на 1, а четные на 10, как требовалось.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
