Вопрос задан 25.07.2023 в 07:53.
Предмет Информатика.
Спрашивает Алексеева Катя.
Информатика, ПАСКАЛЬ Напишите программу, перемещающую все нулевые элементы в конец массива 80
очков, помогите пожалуйста!!!!Ответы на вопрос
Отвечает Решанов Даниил.
const n = 10;
var
mas: array [1..n] of integer;
i,j,h:integer;
begin
randomize;
for i := 1 to n do
begin
mas[i] := random(3);
write(' ',mas[i],' ');
end;
writeln();
for i := 1 to n - 1 do
for j := 1 to n - i do
if(mas[j] = 0) then
begin
h := mas[j];
mas[j] := mas[j + 1];
mas[j + 1] := h;
end;
for i := 1 to n do
write(' ',mas[i],' ');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Паскаль, которая перемещает все нулевые элементы в конец массива:
pascalprogram MoveZerosToEnd; const MaxSize = 100; type IntArray = array[1..MaxSize] of Integer; var arr: IntArray; n, i, zeroCount: Integer; procedure Swap(var a, b: Integer); var temp: Integer; begin temp := a; a := b; b := temp; end; procedure MoveZerosToTheEnd(var arr: IntArray; n: Integer); var i, nonZeroIndex: Integer; begin nonZeroIndex := 1; for i := 1 to n do begin if arr[i] <> 0 then begin Swap(arr[i], arr[nonZeroIndex]); Inc(nonZeroIndex); end; end; end; begin WriteLn('Введите размер массива (не более ', MaxSize, '): '); ReadLn(n); WriteLn('Введите элементы массива:'); for i := 1 to n do ReadLn(arr[i]); MoveZerosToTheEnd(arr, n); WriteLn('Массив с нулевыми элементами в конце:'); for i := 1 to n do WriteLn(arr[i]); end.
Программа запрашивает размер массива и его элементы, затем перемещает все нулевые элементы в конец массива. В результате вы увидите массив с нулевыми элементами, расположенными в его конце.
Похожие вопросы
Информатика 25
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
