Вопрос задан 24.07.2023 в 23:34.
Предмет Информатика.
Спрашивает Зайцев Даниил.
Написать программу на языке с++, с циклом while: с клавиатуры вводится натуральное число n, вывести
на экран цифры этого числа, и я так понимаю цифры должны быть прописаны словами, но это не точно. ДАЮ 35 БАЛЛОВ!!!!!!Ответы на вопрос
Отвечает Кусайко Александр.
Ты задание само скинь, а то так не понятно, что ты написал
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программу на C++, которая будет выводить цифры введенного натурального числа словами. Ниже представлен код программы:
cpp#include <iostream>
#include <string>
std::string digitToWord(int digit) {
switch (digit) {
case 0:
return "ноль";
case 1:
return "один";
case 2:
return "два";
case 3:
return "три";
case 4:
return "четыре";
case 5:
return "пять";
case 6:
return "шесть";
case 7:
return "семь";
case 8:
return "восемь";
case 9:
return "девять";
default:
return "";
}
}
int main() {
int n;
std::cout << "Введите натуральное число: ";
std::cin >> n;
if (n == 0) {
std::cout << "ноль";
return 0;
}
if (n < 0) {
std::cout << "Число должно быть натуральным." << std::endl;
return 1;
}
std::cout << "Цифры числа " << n << " прописью: ";
while (n > 0) {
int digit = n % 10;
std::string word = digitToWord(digit);
std::cout << word << " ";
n /= 10;
}
std::cout << std::endl;
return 0;
}
Когда программа запустится, она запросит вас ввести натуральное число с клавиатуры. Затем программа выведет цифры этого числа словами на экран. Например, для числа 567 программа выведет: "пять шесть семь".
Похожие вопросы
Информатика 78
Информатика 94
Информатика 345
Информатика 12
Информатика 69
Информатика 503
Информатика 28
Информатика 19
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
