СРОЧНО написать программу которая выведет последовательность из N случайных чисел от - k да +k.
Pascal ABCОтветы на вопрос
Program fantscrin;
Var a: array [1..1000] of integer;
i,k,n:integer;
Begin
write('К = '); readln(k);
write('N = '); readln(n);
for i:=1 to n do
a[i]:=random(k*2)-k;
for i:=1 to n do
write(a[i], ' ');
End.
Для решения этой задачи на языке Pascal ABC можно использовать генератор случайных чисел и циклы. Вот пример программы, которая выводит последовательность из N случайных чисел от -k до +k:
pascalprogram RandomNumbers; const N = 10; // Количество случайных чисел k = 100; // Ограничение на диапазон случайных чисел (-k до +k) var i: integer; randomNumber: integer; begin Randomize; // Инициализация генератора случайных чисел writeln('Последовательность из ', N, ' случайных чисел от -', k, ' до +', k, ':'); for i := 1 to N do begin randomNumber := Random(2 * k + 1) - k; // Генерируем случайное число от -k до +k write(randomNumber, ' '); end; writeln; end.
Программа генерирует N случайных чисел от -k до +k с использованием функции Random, которая возвращает случайное целое число от 0 до указанного значения (в данном случае, 2 * k + 1). Затем из этого случайного числа вычитается k, чтобы получить число в диапазоне от -k до +k.
Обратите внимание, что при каждом запуске программы, последовательность случайных чисел будет разной.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
