Написать программу на С++, которая выводит на екран значение функции у = -2,4х2-5x+3 в диапазоне от
-4 до 4, с шагом изменения аргумента в 1. (использовать цыкл for).Ответы на вопрос
#include "pch.h"
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "rus");
double x = -4.0;
double y = 0.0;
for (x;x<=4;)
{
y = -2.4 * x*x - 5*x + 3;
cout << "X = " << x << endl;
cout << "Y = " << y << endl<<endl<<endl;
x++;
}
return 0;
}
Для написания программы на C++, которая выводит значения функции у = -2.4x^2 - 5x + 3 в заданном диапазоне с шагом 1, можно использовать цикл for. Вот пример такой программы:
cpp#include <iostream>
double calculateFunctionValue(double x) {
return -2.4 * x * x - 5 * x + 3;
}
int main() {
int lowerBound = -4;
int upperBound = 4;
std::cout << "x\t| y\n";
std::cout << "----------------\n";
for (int x = lowerBound; x <= upperBound; x++) {
double y = calculateFunctionValue(x);
std::cout << x << "\t| " << y << "\n";
}
return 0;
}
Эта программа определяет функцию calculateFunctionValue, которая принимает значение x и вычисляет соответствующее значение функции y. Затем в функции main происходит итерация по заданному диапазону значений x от -4 до 4 с шагом 1, и выводятся соответствующие значения x и y.
Результатом выполнения программы будет таблица с значениями функции в указанном диапазоне:
diffx | y
----------------
-4 | 7.6
-3 | 0.6
-2 | -8.6
-1 | -13.4
0 | 3
1 | -4.4
2 | -11.4
3 | -12.6
4 | -7.2
Каждая строка представляет пару значений x и соответствующего y, рассчитанного с помощью функции calculateFunctionValue.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
