Вопрос задан 24.07.2023 в 12:54. Предмет Информатика. Спрашивает Кот Ренат.

PascalABC. Составьте программу, которая формирует массив из 15 случайных целых чисел, каждое из

которых находится в диапазоне от -10 до 10 и выводит на экран: а) Максимальный элемент массива б) Индекс максимального элемента массива
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шаханова Аяулым.

program fantscrin;

 const n = 15;

 var a: array [1..n] of integer;

     i,max,max_i:integer;

Begin

 for i:=1 to n do

   a[i]:= random(21)-10;

 for i:=1 to n do

   write(a[i], '  ');

   

 max:=a[1];

 max_i:=1;

 for i:=2 to n do

   if (a[i]>max) then  

                 begin

                   max:=a[i];

                   max_i:=i;

                 end;

 writeln('');

 writeln('Элемент: ', max);

 writeln('Индекс: ', max_i);

End.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для создания программы на языке PascalABC, которая формирует массив из 15 случайных целых чисел в диапазоне от -10 до 10 и выводит на экран максимальный элемент массива и его индекс, следуйте следующему коду:

pascal
program MaxElementAndIndex; const SIZE = 15; MIN_VALUE = -10; MAX_VALUE = 10; var arr: array[1..SIZE] of integer; maxElement, maxIndex, i: integer; begin Randomize; // Инициализация генератора случайных чисел // Заполнение массива случайными числами for i := 1 to SIZE do arr[i] := Random(MAX_VALUE - MIN_VALUE + 1) + MIN_VALUE; // Вывод массива на экран writeln('Массив:'); for i := 1 to SIZE do write(arr[i]:4); writeln; // Поиск максимального элемента и его индекса maxElement := arr[1]; maxIndex := 1; for i := 2 to SIZE do begin if arr[i] > maxElement then begin maxElement := arr[i]; maxIndex := i; end; end; // Вывод максимального элемента и его индекса на экран writeln('Максимальный элемент массива: ', maxElement); writeln('Индекс максимального элемента: ', maxIndex); end.

Этот код создаст массив из 15 случайных целых чисел в диапазоне от -10 до 10, выведет его на экран, а затем найдет максимальный элемент и его индекс и также выведет их на экран. Обратите внимание, что генератор случайных чисел инициализируется вызовом функции Randomize, чтобы каждый раз при запуске программы получать различные случайные числа.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос