По С++ Ввести массив, состоящий из 14 элементов целого типа. Найти количество элементов четных по
значению. И Ввести целочисленный массив, состоящий из 9 элементов. Найти максимальный и минимальный элементы массива.Ответы на вопрос
#include "pch.h"
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "rus");
const int dlinna = 14, dlinna2 = 9 ;
int arr[dlinna],chetnie = 0;
cout << "Введите значения массива на 14 элементов!" << endl;
for (int i = 0; i < dlinna; ) {
cin >> arr[i];
if (arr[i] % 2 == 0) {
chetnie++;
}
i++;
}
cout << "Количество четных элементов массива = " << chetnie << endl << endl;
int arr2[dlinna2];
int min= 2147483647, max=-2147483647;
cout << "Теперь введите значения массива на 9 элементов !" << endl;
for (int j = 0; j < dlinna2; j++) {
cin >> arr[j];
if(arr[j] < min) {
min = arr[j];
}if (arr[j] > max) {
max = arr[j];
}
}
cout << "Минимальный элемент массива = " << min << endl;
cout << "Максимальный элемент массива = " << max << endl;
}
Для решения обеих задач вам понадобится написать программу на языке С++. Вот два примера программы для выполнения задачи:
- Найти количество четных элементов в массиве из 14 элементов:
cpp#include <iostream>
int main() {
const int size = 14;
int array[size];
int evenCount = 0;
// Ввод массива
std::cout << "Введите " << size << " элементов массива:\n";
for (int i = 0; i < size; i++) {
std::cin >> array[i];
if (array[i] % 2 == 0) {
evenCount++;
}
}
// Вывод результата
std::cout << "Количество четных элементов в массиве: " << evenCount << std::endl;
return 0;
}
- Найти максимальный и минимальный элементы в массиве из 9 элементов:
cpp#include <iostream>
int main() {
const int size = 9;
int array[size];
int maxElement, minElement;
// Ввод массива
std::cout << "Введите " << size << " элементов массива:\n";
for (int i = 0; i < size; i++) {
std::cin >> array[i];
}
// Поиск максимального и минимального элементов
maxElement = minElement = array[0];
for (int i = 1; i < size; i++) {
if (array[i] > maxElement) {
maxElement = array[i];
}
if (array[i] < minElement) {
minElement = array[i];
}
}
// Вывод результата
std::cout << "Максимальный элемент: " << maxElement << std::endl;
std::cout << "Минимальный элемент: " << minElement << std::endl;
return 0;
}
Обратите внимание, что оба примера предполагают, что пользователь будет вводить числа с клавиатуры. После ввода каждого элемента массива нажмите клавишу "Enter". После завершения ввода программы вычислят результаты и выведут их на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
