Вопрос задан 24.07.2023 в 09:48.
Предмет Информатика.
Спрашивает Суханов Никита.
Составить программу вывода на центр экрана надписи жёлтого цвета Я люблю свою родину(срочно)
Ответы на вопрос
Отвечает Октябрьская Мария.
program first;
uses crt;
begin
writeln ('"Я люблю свою Родину!"');
textcolor(yellow);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для составления программы вывода надписи на центр экрана с использованием языка программирования Python и библиотеки Tkinter (стандартная библиотека для создания графических пользовательских интерфейсов), следуйте этому примеру:
pythonimport tkinter as tk
def center_window(window, width, height):
screen_width = window.winfo_screenwidth()
screen_height = window.winfo_screenheight()
x = (screen_width // 2) - (width // 2)
y = (screen_height // 2) - (height // 2)
window.geometry(f"{width}x{height}+{x}+{y}")
def main():
root = tk.Tk()
root.title("Центрирование надписи")
label_text = "Я люблю свою родину"
label_color = "yellow"
label = tk.Label(root, text=label_text, bg="white", fg=label_color, font=("Helvetica", 24, "bold"))
label.pack(padx=20, pady=20)
center_window(root, 400, 200)
root.mainloop()
if __name__ == "__main__":
main()
Скопируйте данный код в файл с расширением .py и запустите его. Окно с надписью "Я люблю свою родину" жёлтого цвета появится на центре экрана.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
