1. Напишите программу которая даст 12 слагаемых чисел из [-35..35] и вычислить их сумму. 2.
Напишите программу, которая вычислить в байтах длину введённого текста.Срочно, пожалуйста!ПаскальОтветы на вопрос
Первая программа
var number, i, summa: integer;
begin
summa := 0;
randomize;
for i := 0 to 12 do begin
number := random(-35,35);
writeln(number);
summa := summa + number;
end;
writeln(summa);
end.
Вторая программа
var text:string;
i, len:integer;
begin
len := 0;
readln(text);
for i := 0 to length(text)-1 do begin
len := len + 1;
end;
writeln(len*SizeOf(string));
end.
Конечно, вот две программы: первая программа на языке Pascal для вычисления суммы 12 случайных чисел из диапазона [-35..35], а вторая программа для вычисления длины введенного текста в байтах.
Программа на Pascal для вычисления суммы 12 случайных чисел:
pascalprogram SumOfRandomNumbers; uses SysUtils; var i, number, sum: Integer; begin Randomize; // Инициализируем генератор случайных чисел sum := 0; // Обнуляем сумму // Генерируем 12 случайных чисел и вычисляем их сумму for i := 1 to 12 do begin number := Random(71) - 35; // Генерируем число от -35 до 35 Write(number, ' '); // Выводим число на экран sum := sum + number; // Добавляем число к сумме end; Writeln; // Перевод строки Writeln('Сумма:', sum); // Выводим сумму на экран Readln; // Ждем, пока пользователь нажмет Enter end.
Программа на Pascal для вычисления длины введенного текста в байтах:
pascalprogram TextLengthInBytes; uses SysUtils; var inputText: String; textLengthInBytes: Integer; begin Write('Введите текст: '); Readln(inputText); // Считываем введенный текст textLengthInBytes := Length(inputText) * SizeOf(Char); // Вычисляем длину введенного текста в байтах Writeln('Длина текста в байтах:', textLengthInBytes); // Выводим длину на экран Readln; // Ждем, пока пользователь нажмет Enter end.
Эти программы помогут вам решить задачи, описанные в вашем запросе. Надеюсь, они будут полезны! Если у вас возникнут вопросы или понадобится дополнительная помощь, не стесняйтесь спрашивать. Удачи в программировании!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
