Вопрос задан 23.07.2023 в 15:11.
Предмет Информатика.
Спрашивает Гридасова Ксения.
Напишите программу, которая заполняет массив из 20 случайных элементов на отрезке [10;1000] и
находит отдельно сумму элементов в первой и второй половинах массива.( На языке Паскаль, спасибо!)Ответы на вопрос
Отвечает Алексеев Кирилл.
var a : array [1..20] of integer;
i, s1, s2: integer;
begin
s1 := 0;
s2 := 0;
randomize;
for i := 1 to 20 do
begin
a[i] := random(991) + 10;
if (i < 11) then
s1 += a[i]
else
s2 += a[i];
end;
writeln(s1);
writeln(s2);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот программа на языке Паскаль, которая заполняет массив из 20 случайных элементов на отрезке [10;1000] и находит отдельно сумму элементов в первой и второй половинах массива:
pascalprogram SumOfArrayHalves; const N = 20; var arr: array[1..N] of Integer; i: Integer; sumFirstHalf, sumSecondHalf: Integer; begin Randomize; // Инициализируем генератор случайных чисел // Заполняем массив случайными числами от 10 до 1000 for i := 1 to N do arr[i] := Random(991) + 10; // Random(X) генерирует случайное число от 0 до X-1 // Выводим массив на экран writeln('Массив:'); for i := 1 to N do write(arr[i], ' '); // Вычисляем суммы элементов в первой и второй половинах массива sumFirstHalf := 0; sumSecondHalf := 0; for i := 1 to N div 2 do sumFirstHalf := sumFirstHalf + arr[i]; for i := N div 2 + 1 to N do sumSecondHalf := sumSecondHalf + arr[i]; // Выводим суммы на экран writeln; writeln('Сумма элементов в первой половине массива: ', sumFirstHalf); writeln('Сумма элементов во второй половине массива: ', sumSecondHalf); readln; end.
Программа заполняет массив случайными числами, выводит его на экран и вычисляет сумму элементов в первой и второй половинах массива, выводя результаты на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 35
Информатика 39
Информатика 22
Информатика 267
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
