Те кто работает с паскалем. Помогите пж. Зал кинотеатра вмещает 35 рядов кресел по 40 мест в ряду.
Стоимость билетов с 1 по 10 ряд 250 руб, с 11-20 ряд 400р, 21-35 по 500р. Составить программу вычисления общей стоимости билетов, если зал заполнен.Ответы на вопрос
begin
writeln('стоимость всех билетов составит: ', 40*10*250+40*10*400+40*15*500);
end.
или еще вариант
var
s : integer; // сумма за все билеты
const
n : integer = 40; // количество кресел в ряду
begin
s := n*10*250+n*10*400+n*15*500; // находим сумму
writeln('стоимость всех билетов составит: ', s); // выводим результат
end.
Для решения этой задачи можно использовать язык программирования Паскаль. Ниже приведен пример программы на Паскале, которая вычисляет общую стоимость билетов в кинотеатре при заданных условиях:
pascalprogram CinemaTickets; const Rows = 35; // Количество рядов SeatsPerRow = 40; // Количество мест в ряду PriceTier1 = 250; // Стоимость билета для 1-10 рядов PriceTier2 = 400; // Стоимость билета для 11-20 рядов PriceTier3 = 500; // Стоимость билета для 21-35 рядов var TotalTicketsSold: Integer; TotalRevenue: Integer; Row, Seat: Integer; TicketPrice: Integer; begin TotalTicketsSold := Rows * SeatsPerRow; TotalRevenue := 0; for Row := 1 to Rows do begin if Row <= 10 then TicketPrice := PriceTier1 else if Row <= 20 then TicketPrice := PriceTier2 else TicketPrice := PriceTier3; for Seat := 1 to SeatsPerRow do begin TotalRevenue := TotalRevenue + TicketPrice; end; end; writeln('Общая стоимость билетов: ', TotalRevenue, ' руб.'); end.
Программа рассчитывает общее количество проданных билетов и общую выручку от продажи билетов в соответствии с заданными ценами на разные ряды. Затем выводит результат на экран. Учтите, что в данном примере мы предполагаем, что весь зал заполнен, и билеты продаются по максимальной стоимости в каждом ряду.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
