Вопрос задан 22.07.2023 в 21:06.
Предмет Информатика.
Спрашивает Басанец Сёма.
Составьте программу подсчёта размера оплаты за электроэнергию по показаниями счётчика и тарифу. На
вход поступают 3 числа. Первое число -- целое число. Показания счётчика в кВт*ч на начало месяца.Второе число -- целое число. Показания счётчика в кВт*ч на конец месяца.Третье число -- вещественное число. Стоимость одного кВт*ч в рублях.Программа должны вывести на экран размер оплаты за электроэнергию. Результат выведите с двумя знаками после запятой.Задача на языке C.Ответы на вопрос
Отвечает Марчук Максим.
#include<stdio.h>
void main()
{
float coast, result;
int beginm, endm;
printf("Задайте показания счетчика на начало месяца ");
scanf("%d", &beginm);
printf("\nЗадайте показания счетчика на конец месяца ");
scanf("%d", &endm);
printf("\n Задайте стоимость 1 кВт ч ");
scanf("%f", &coast);
result=(endm-beginm)*coast;
printf("\n\n Месячная оплата за электроэнергию составит: .2%f\n", result);
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Ниже приведена программа на языке C для подсчёта размера оплаты за электроэнергию по показаниям счётчика и тарифу:
c#include <stdio.h>
int main() {
int start_reading, end_reading;
float tariff, consumption, total_payment;
// Ввод показаний счётчика и тарифа
printf("Введите показания счётчика на начало месяца (кВт*ч): ");
scanf("%d", &start_reading);
printf("Введите показания счётчика на конец месяца (кВт*ч): ");
scanf("%d", &end_reading);
printf("Введите стоимость одного кВт*ч в рублях: ");
scanf("%f", &tariff);
// Рассчёт потребления
consumption = end_reading - start_reading;
// Рассчёт оплаты за электроэнергию
total_payment = consumption * tariff;
// Вывод результата с двумя знаками после запятой
printf("Размер оплаты за электроэнергию: %.2f руб.\n", total_payment);
return 0;
}
Программа запрашивает у пользователя показания счётчика на начало и конец месяца, а также стоимость одного кВт*ч в рублях. Затем она рассчитывает потребление и оплату за электроэнергию, выводит результат на экран с двумя знаками после запятой.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 20
Информатика 267
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
