
напишите программу решения следующей задачи:Создать двумерный динамический массив произвольного
размера .Ввести значения элементов массива.Найти значение минимального элемента массива,поменять его местами с первым элементом

Ответы на вопрос

#include <iostream>
#include <time.h>
using namespace std;
int main()
{
srand(time(0));
int a, b;
int min = 100, posI, posJ;
cin >> a >> b;
int** matrix = new int*[a];
for (int i = 0; i < a; i++)
matrix[i] = new int[b];
for (int i = 0; i < a; i++)
{
for (int j = 0; j < b; j++)
matrix[i][j] = rand() % min;
}
for (int i = 0; i < a; i++)
{
for (int j = 0; j < b; j++)
cout << matrix[i][j] << '\t';
cout << endl;
}
for (int i = 0; i < a; i++)
{
for (int j = 0; j < b; j++)
if (matrix[i][j] < min)
{
posI = i;
posJ = j;
min = matrix[i][j];
}
}
matrix[posI][posJ] = matrix[0][0];
matrix[0][0] = min;
cout << endl;
for (int i = 0; i < a; i++)
{
for (int j = 0; j < b; j++)
cout << matrix[i][j] << '\t';
cout << endl;
}
for (int i = 0; i < a; i++)
delete[] matrix[i];
delete[] matrix;
system("pause");
return 0;
}



Для решения этой задачи на языке программирования C++ можно воспользоваться следующим кодом. Программа создает двумерный динамический массив, заполняет его значениями, находит минимальный элемент и меняет его местами с первым элементом:
cpp#include <iostream>
int main() {
// Задаем размеры массива
int rows, cols;
std::cout << "Введите количество строк: ";
std::cin >> rows;
std::cout << "Введите количество столбцов: ";
std::cin >> cols;
// Создаем двумерный динамический массив
int** arr = new int*[rows];
for (int i = 0; i < rows; ++i) {
arr[i] = new int[cols];
}
// Вводим значения элементов массива
std::cout << "Введите значения элементов массива:\n";
for (int i = 0; i < rows; ++i) {
for (int j = 0; j < cols; ++j) {
std::cin >> arr[i][j];
}
}
// Находим минимальный элемент
int minElement = arr[0][0];
for (int i = 0; i < rows; ++i) {
for (int j = 0; j < cols; ++j) {
if (arr[i][j] < minElement) {
minElement = arr[i][j];
}
}
}
// Меняем минимальный элемент с первым элементом
int temp = arr[0][0];
arr[0][0] = minElement;
for (int i = 0; i < rows; ++i) {
for (int j = 0; j < cols; ++j) {
if (arr[i][j] == minElement) {
arr[i][j] = temp;
break;
}
}
}
// Выводим массив после замены
std::cout << "Массив после замены:\n";
for (int i = 0; i < rows; ++i) {
for (int j = 0; j < cols; ++j) {
std::cout << arr[i][j] << " ";
}
std::cout << std::endl;
}
// Освобождаем выделенную память
for (int i = 0; i < rows; ++i) {
delete[] arr[i];
}
delete[] arr;
return 0;
}
Пожалуйста, обратите внимание, что ввод элементов массива не предполагает никаких проверок на корректность, поэтому стоит быть осторожным при вводе данных. Также не забудьте освободить динамическую память после окончания работы с массивом.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili