Вопрос задан 21.07.2023 в 13:09.
Предмет Информатика.
Спрашивает Карпов Герман.
1.Напиши программу ввода значения А, В, С в одной строке и выведите результат выражения
(А+В/5,12)*(С-3,12) в отдельной строке. 2.Составьте программу, вычисляющую, сколько процентов от А+В-С приходится: на А, на В, на С?Ответы на вопрос
Отвечает Дюсьмекеев Николай.
var a,b,c,y: real;
begin
writeln('Введите значение a: ');
readln(a);
writeln('Введите значение b: ');
readln(b);
writeln('Введите значение c: ');
readln(c);
y:=(a+b/5.12)*(c-3.12);
writeln('a = ',a,' b = ',b,' c = ',c);
writeln('y = ',y);
end.
2 задание вообще не понятно...
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для обеих задач предполагается использование языка программирования Python. Давайте решим каждую задачу по очереди:
- Программа для вычисления выражения (А+В/5.12)*(С-3.12):
python# Считываем значения А, В, С в одной строке и разделяем их по пробелу
input_string = input("Введите значения А, В, С через пробел: ")
A, B, C = map(float, input_string.split())
# Вычисляем результат выражения
result = (A + B / 5.12) * (C - 3.12)
# Выводим результат
print("Результат выражения: ", result)
- Программа для вычисления процентного соотношения А, В, С от А + В - С:
python# Считываем значения А, В, С в одной строке и разделяем их по пробелу
input_string = input("Введите значения А, В, С через пробел: ")
A, B, C = map(float, input_string.split())
# Вычисляем сумму А + В - С
total_sum = A + B - C
# Вычисляем процентное соотношение каждого значения
percent_A = (A / total_sum) * 100
percent_B = (B / total_sum) * 100
percent_C = (C / total_sum) * 100
# Выводим результат
print(f"Процентное соотношение на А: {percent_A:.2f}%")
print(f"Процентное соотношение на В: {percent_B:.2f}%")
print(f"Процентное соотношение на С: {percent_C:.2f}%")
Обратите внимание, что в первой программе используется оператор деления "/", а во второй программе используется оператор "-" для вычисления разницы между А, В и С.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
