ИНФОРМАТИКА СРОЧНО СОСТАВИТЬ ПРОГРАММУ В ПАСКАЛЕ И НАПИШИТЕ ПОЖАЛУЙСТА, ЧТО ОБОЗНАЧАЕТ ПЕРЕМЕННЫЕ
И m:=26*round(a*100/67); ВОТ ЭТУ СТРОКУ В ЧАСТНОСТИ В течение месяца бригада каждый следующий день работы выпускает на три изделия больше предыдущего. В первый день выпущено 42 изделия, что составило 67% дневной нормы. Выполнит ли бригада месячную норму? (Считать в месяце 26 рабочих дней)Ответы на вопрос
Program zadacha;
var a1,a26, norm1,norm26,S, d: real;
n:integer;
begin
a1:=42;
d:=3;
n:=26;
norm1:=round(a1*100/67);//найдем дневную норму и округлим ее
a26:= a1+d*(n-1);//бригада выполнит в 26-й день, 26-й член арифметической прогрессии, где разность=3
norm26:= norm1*n;//найдем норму за 26 рабочих дней
S:= (a1+a26)*26/2;//сумма 26-сти членов арифметической прогрессии, все изделия за 26 дней
//вывод на экран промежуточных вычислений не обязателен
writeln ('норма за один день = ',norm1);
writeln ('изделий в 26-й день = ',a26);
writeln ('норма за 26 дней = ',norm26);
writeln ('всего изделий за 26 дней = ',S);
if S >= norm26 then
writeln ('бригада выполнит месячную норму')
else
writeln ('бригада не выполнит месячную норму');
end.
//В вашем условии m - это норма за месяц, т.е. за 26 рабочих дней
Для решения данной задачи вам потребуется написать программу на языке Pascal, которая будет моделировать процесс выпуска изделий и проверять, выполнила ли бригада месячную норму.
Переменные в программе будут использоваться для хранения данных о количестве изделий, дневной норме и других вспомогательных значений.
Вот программа на Pascal для решения задачи:
pascalprogram Production; var day: integer; // День месяца dailyOutput, monthlyOutput, dailyNorm: integer; // Количество изделий в день, за месяц, дневная норма a: real; // Процент от дневной нормы m: integer; // Итоговое количество изделий на месяц success: boolean; // Флаг успешного выполнения месячной нормы begin // Известные данные dailyOutput := 42; a := 67 / 100; day := 1; dailyNorm := 42 / a; // Расчет месячного выпуска изделий while day <= 26 do begin m := m + dailyOutput; // Прибавляем изделия за текущий день dailyOutput := dailyOutput + 3; // Увеличиваем производство на 3 изделия на следующий день Inc(day); // Переходим к следующему дню end; // Проверяем, выполнила ли бригада месячную норму if m >= dailyNorm * 26 then success := true else success := false; // Выводим результат writeln('Итоговый выпуск за месяц:', m); if success then writeln('Бригада выполнила месячную норму.') else writeln('Бригада не выполнила месячную норму.'); readln; // Чтобы программа не закрылась сразу после вывода результатов end.
Пояснения к программе:
- Переменные
day,dailyOutput,dailyNormиспользуются для моделирования процесса выпуска изделий на каждый день и для определения дневной нормы. - Переменная
mиспользуется для подсчета итогового количества изделий за месяц. - Флаг
successопределяет, выполнила ли бригада месячную норму. Еслиsuccessравноtrue, значит, норма выполнена, иначе - не выполнена. - Выводится итоговое количество выпущенных изделий за месяц и результат о выполнении месячной нормы.
Пожалуйста, скопируйте код и выполните его в среде разработки Pascal, чтобы получить результаты.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
