
Срочно!!!Хелп ми плиииз Дана программа на языке Паскаль: program a2; var a, b, с, min: real;
begin writeln ('Введите три числа'); readln (a, b, с); min := а; if b if c writeln ('min=',min) end. Что будет результатом работы программы при следующих исхожных данных, 1)a = 10 b = 5 c = 1 2)a = 10 b = 5 c = 7 3)a = 2 b = 10 c = 5 постройте блок схему соответствующую программе.

Ответы на вопрос

для начала вот правильно написанная программа
Program a2;
var a, b, c, min: real;
begin
writeln ('Введите три числа');
readln (a, b, c);
if a<b then min:=a else min:=b;
if c<min then min:=c;
writeln('min=',min);
end.
1) c
2) b
3) a



Данная программа на языке Паскаль является некорректной, так как содержит синтаксические ошибки. Вероятно, вам нужно написать программу для нахождения минимального из трех чисел. В таком случае, исправленный код программы и результаты ее работы для предоставленных исходных данных будут следующими:
Исправленный код программы на языке Паскаль:
pascalprogram a2; var a, b, c, min: real; begin writeln('Введите три числа'); readln(a, b, c); min := a; if b < min then min := b; if c < min then min := c; writeln('min=', min); end.
Теперь рассмотрим результаты работы программы для предоставленных исходных данных:
a = 10, b = 5, c = 1: Результат: min = 1
a = 10, b = 5, c = 7: Результат: min = 5
a = 2, b = 10, c = 5: Результат: min = 2
Блок-схема для исправленной программы:
lua+-----------------+
| Введите три числа |
+-----------------+
|
v
+-----------------+
| считать a, b, c |
+-----------------+
|
v
+-----------------+
| min := a |
+-----------------+
|
v
+-------------------+
| если b < min |
| то min := b |
+-------------------+
|
v
+-------------------+
| если c < min |
| то min := c |
+-------------------+
|
v
+-----------------+
| вывести min |
+-----------------+
Надеюсь, что это поможет вам разобраться с программой и блок-схемой! Если у вас есть еще вопросы или запросы, не стесняйтесь обращаться.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili