Вопрос задан 20.07.2023 в 09:31.
Предмет Информатика.
Спрашивает Лапутин Паша.
Возрастает или нет? PASCAL ABC Дано натуральное число n. Необходимо определить, является ли
последовательность его цифр при просмотре справа налево упорядоченной по возрастанию.Формат входных данныхВводится целое число n (1≤n≤231−1).Формат выходных данныхВыведите «YES», если условие задачи выполняется, и «NO» в противном случае.Примерывходные данные выходные данные5321----------------------------YES7820----------------------------NOОтветы на вопрос
Отвечает Сидоров Александр.
Var x, k, a,s, b:Integer ;
Begin
Write ('x=') ;read(x) ;
B:=-1;k:=0;s:=0;
While x>0 do begin
A:=x mod 10;
If a>b then k:=k+1;
S:=s+1;
X:=x div 10;b:=a;
End;
If k=s then writeln('YES') Else writeln('NO') ;
End.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи можно преобразовать число n в строку, а затем просмотреть его цифры справа налево, проверяя, является ли последовательность цифр упорядоченной по возрастанию. Если это условие выполняется, выводим "YES", иначе "NO".
Пример алгоритма на языке Pascal ABC:
pascalfunction IsDigitsAscending(n: integer): boolean; var numStr: string; i: integer; begin numStr := IntToStr(n); for i := Length(numStr) - 1 downto 1 do begin if Ord(numStr[i]) < Ord(numStr[i + 1]) then Exit(false); end; Exit(true); end; var n: integer; begin Readln(n); if IsDigitsAscending(n) then Writeln('YES') else Writeln('NO'); end.
Пример работы программы:
yamlВходные данные: 5321
Выходные данные: YES
Входные данные: 7820
Выходные данные: NO
Обратите вним
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
