 
Дан массив C(m). Найти отношение максимального к минимальному элементу. Написать программу в
Pascal,пожалуйста 0
        0
         0
        0
    Ответы на вопрос
 
        const m=10;
var c:array[1..m] of integer;
max,min,i,j: integer;
begin
writeln('Массив:');
for i:=1 to m do
begin
c[i]:=random(50);
write(c[i],' ');
end;
writeln;
max:=c[1];
min:=c[1];
for i:=2 to m do
begin
if c[i]>max then max:=c[i];
if c[i]<min then min:=c[i];
end;
writeln('max = ',max,' min = ',min,' max/min = ',max/min:5:2);
end.
Пример:
Массив:
27 29 35 42 30 42 27 42 21 31
max = 42 min = 21 max/min = 2.00
 0
                    0
                     0
                    0
                 
            Конечно! Вот пример программы на языке Pascal, которая находит отношение максимального к минимальному элементу в массиве:
pascalprogram MaxMinRatio; const MAX_SIZE = 100; // Максимальный размер массива type MyArray = array[1..MAX_SIZE] of Integer; var C: MyArray; m, i: Integer; maxElement, minElement: Integer; ratio: Real; procedure FindMaxMin(const arr: MyArray; size: Integer; var maxEl, minEl: Integer); var i: Integer; begin maxEl := arr[1]; minEl := arr[1]; for i := 2 to size do begin if arr[i] > maxEl then maxEl := arr[i]; if arr[i] < minEl then minEl := arr[i]; end; end; begin WriteLn('Введите размер массива m:'); ReadLn(m); if (m < 1) or (m > MAX_SIZE) then begin WriteLn('Неверный размер массива. Размер должен быть от 1 до ', MAX_SIZE); Exit; end; WriteLn('Введите элементы массива C:'); for i := 1 to m do ReadLn(C[i]); FindMaxMin(C, m, maxElement, minElement); WriteLn('Максимальный элемент: ', maxElement); WriteLn('Минимальный элемент: ', minElement); if minElement = 0 then begin WriteLn('Ошибка! Минимальный элемент равен 0, нельзя выполнить деление.'); Exit; end; ratio := maxElement / minElement; WriteLn('Отношение максимального к минимальному элементу: ', ratio:0:2); end.
Программа сначала запрашивает у пользователя размер массива m и его элементы. Затем она находит максимальный и минимальный элементы и выполняет деление максимального элемента на минимальный, выводя результат на экран.
Убедитесь, что ваша среда разработки поддерживает язык Pascal и может выполнять программы на этом языке.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			