Вопрос задан 20.07.2023 в 03:25.
Предмет Информатика.
Спрашивает Григорьева Марина.
Напишите программу, которая при вводе латинской буквы сообщает главная она или согласная.
Использовать тип данных символьный char.Ответы на вопрос
Отвечает Мансуров Ислам.
var c: char;
vowels: set of char:=['a', 'e', 'i', 'o', 'u', 'y'];
begin
write('Введите символ: ');
readln(c);
if c in vowels then
writeln(c, ' — гласная')
else
writeln(c, ' — согласная');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот простая программа на языке C, которая определяет, является ли введенная пользователем латинская буква гласной или согласной:
c#include <stdio.h>
int main() {
char ch;
printf("Введите латинскую букву: ");
scanf("%c", &ch);
// Преобразуем символ к верхнему регистру, чтобы сравнивать только с заглавными буквами
ch = toupper(ch);
if (ch >= 'A' && ch <= 'Z') {
if (ch == 'A' || ch == 'E' || ch == 'I' || ch == 'O' || ch == 'U') {
printf("Это гласная буква.\n");
} else {
printf("Это согласная буква.\n");
}
} else {
printf("Ошибка! Введенный символ не является латинской буквой.\n");
}
return 0;
}
Программа будет просить пользователя ввести латинскую букву, а затем сообщит, является она гласной или согласной. Обратите внимание, что программа считает только заглавные буквы (A-Z) и игнорирует любые другие символы, введенные пользователем.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
