Задача по программированию на С++ Написать программу, которая будет генерировать массив из 30
случайных чисел в промежутке от -10 до 10 и выводить его на экранОтветы на вопрос
Ответ:
#include <iostream>
#include <time.h>
int main()
{
srand(time(NULL));
int numbers[30];
for (int i = 0; i < 30; i++) {
numbers[i] = -10 + rand() % 21;
}
for (int i = 0; i < 30; i++) {
std::cout << numbers[i] << "\t";
}
return 0;
}
Объяснение:
Для создания программы на C++, которая генерирует массив из 30 случайных чисел в промежутке от -10 до 10 и выводит его на экран, можно использовать стандартную библиотеку C++ для работы с генерацией случайных чисел. Вам понадобятся функции rand() и srand() из библиотеки <cstdlib>, чтобы генерировать случайные числа. Также вам понадобится библиотека <iostream> для вывода на экран.
Вот пример программы:
cpp#include <iostream>
#include <cstdlib>
#include <ctime>
const int ARRAY_SIZE = 30;
const int MIN_VALUE = -10;
const int MAX_VALUE = 10;
int main() {
// Инициализация генератора случайных чисел текущим временем
std::srand(static_cast<unsigned int>(std::time(nullptr)));
int array[ARRAY_SIZE];
// Заполнение массива случайными числами в промежутке от MIN_VALUE до MAX_VALUE
for (int i = 0; i < ARRAY_SIZE; ++i) {
array[i] = std::rand() % (MAX_VALUE - MIN_VALUE + 1) + MIN_VALUE;
}
// Вывод массива на экран
std::cout << "Сгенерированный массив:\n";
for (int i = 0; i < ARRAY_SIZE; ++i) {
std::cout << array[i] << " ";
}
std::cout << std::endl;
return 0;
}
В этой программе, std::srand(static_cast<unsigned int>(std::time(nullptr))) используется для инициализации генератора случайных чисел текущим временем, чтобы каждый раз при запуске программы генерировались новые случайные числа. Затем цикл заполняет массив array случайными числами в заданном диапазоне. Наконец, массив выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
