50 баллов.Напишите программу, которая в последовательности натуральных чисел определяет минимальное
число, кратное 13. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 13. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число - минимальное число, кратное 13. Входные данные 3, 130, 25, 169. Выходные данные 130. (чтобы её можно было запустить в паскаль) Ответы на вопрос
Ответ:
Var i,c,count,min:integer;
Begin
Read (count);
Min:=30000;
For i:=1 to count do
Begin
Read(c);
If c < min and c mod 13 = 0 then
Min:= c;
End;
Write(min);
End.
#include <iostream>
using namespace std;
int main()
{
int b,c,d,e,f,g;
cin >>b;
d=30001;
int A[b];
for ( int i=0;b>i;i++ )
{
cin >> A[i];
}
for ( int i=0;b>i;i++ )
{
if ( A[i]%13 ==0 )
{
if ( A[i]< d )
{
d=A[i];
}
}
}
cout << d;
}
Для написания программы, которая находит минимальное число, кратное 13, из последовательности натуральных чисел, можно использовать следующий код на языке Pascal:
pascalprogram FindMinimumMultipleOf13; const MAX_NUMBERS = 1000; var sequence: array[1..MAX_NUMBERS] of integer; n, i, minMultipleOf13: integer; begin { Ввод количества чисел в последовательности } writeln('Введите количество чисел в последовательности:'); readln(n); { Ввод чисел в последовательность } writeln('Введите числа:'); for i := 1 to n do readln(sequence[i]); { Ищем минимальное число, кратное 13 } minMultipleOf13 := sequence[1]; for i := 2 to n do begin if (sequence[i] mod 13 = 0) and (sequence[i] < minMultipleOf13) then minMultipleOf13 := sequence[i]; end; { Вывод результата } writeln('Минимальное число, кратное 13: ', minMultipleOf13); end.
Программа предполагает, что в последовательности есть хотя бы одно число, кратное 13, как указано в условии задачи. Она считывает количество чисел в последовательности, а затем сами числа, и находит минимальное число, кратное 13, выводя его на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
