(Паскаль) Составьте программу вывода на экран всех простых чисел, не превосходящих заданного N.
Простым называется натуральное число больше единицы, имеющее только два делителя: единицу и само это число. Для проверки подготовить код программы и результаты ее работы.Ответы на вопрос
Код программы
program raf105;
var i,j,o,n:integer;
begin
write('Введите число N: ');
readln(n);
writeln('Вывод: ');
for i:=2 to n-1 do
begin
o:=0;
for j:= 1 to i do
if (i mod j)=0
then o:= o+1;
if o=2
then writeln(i);
end;
end.
Результаты работы программы
Введите число N: 15
Вывод:
2
3
5
7
11
13
Вот пример программы на языке Паскаль для вывода на экран всех простых чисел, не превосходящих заданного значения N:
pascalprogram PrimeNumbers; var N, i, j: Integer; isPrime: Boolean; begin WriteLn('Введите значение N:'); ReadLn(N); WriteLn('Простые числа, не превосходящие ', N, ':'); // Перебираем числа от 2 до N for i := 2 to N do begin isPrime := True; // Проверяем, является ли текущее число i простым for j := 2 to Trunc(Sqrt(i)) do begin if i mod j = 0 then begin isPrime := False; Break; end; end; // Если число простое, выводим его на экран if isPrime then Write(i, ' '); end; WriteLn; // Перевод строки после вывода всех простых чисел end.
Пользователь будет предоставлен возможность ввести значение N, а затем программа выведет все простые числа, не превосходящие это значение.
Пример работы программы:
yamlВведите значение N:
20
Простые числа, не превосходящие 20:
2 3 5 7 11 13 17 19
Обратите внимание, что данная реализация не является оптимальной с точки зрения эффективности для больших значений N. Существуют более оптимизированные алгоритмы для нахождения простых чисел, такие как Решето Эратосфена, но они могут быть реализованы в другом коде.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
