Вопрос задан 19.07.2023 в 18:11. Предмет Информатика. Спрашивает Олялин Коля.

Дам 70 баллов!!! Надо написать программу на языке Паскаль, которая вычисляет сумму:а) Первых n

натуральных чисел;б) Квадратов первых n натуральных чисел;в) Всех чётных чисел в диапазоне от 1 до n;г) Всех двузначных чисел. Всё это надо написать одной программой через оператора repeat. НЕ С ИНТЕРНЕТА!!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сипченко Данил.

program raf105;

var

 n,i,a,b,c,d,sqrt: integer;

begin

 write('Введите n: ');

 readln(n);

 repeat

   i:= i+1;

   a:= a+i;

   sqrt:= i*i;

   b:= b+sqrt;

   if i mod 2 = 0

     then c:= c+i;

   if (i >= 10) and (i <= 99)

     then d:= d+i;

 until i = n;

 writeln('а) ',a);

 writeln('б) ',b);

 writeln('в) ',c);

 writeln('г) ',d);

end.

PascalABC 3.4.2

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на языке Паскаль, которая вычисляет сумму указанных вами последовательностей. Вот программа:

pascal
program SumCalculations; var n, i, sum: integer; begin writeln('Введите значение n:'); readln(n); { а) Вычисление суммы первых n натуральных чисел } i := 1; sum := 0; repeat sum := sum + i; i := i + 1; until i > n; writeln('Сумма первых ', n, ' натуральных чисел: ', sum); { б) Вычисление суммы квадратов первых n натуральных чисел } i := 1; sum := 0; repeat sum := sum + i * i; i := i + 1; until i > n; writeln('Сумма квадратов первых ', n, ' натуральных чисел: ', sum); { в) Вычисление суммы всех четных чисел в диапазоне от 1 до n } i := 1; sum := 0; repeat if i mod 2 = 0 then sum := sum + i; i := i + 1; until i > n; writeln('Сумма четных чисел в диапазоне от 1 до ', n, ': ', sum); { г) Вычисление суммы всех двузначных чисел } sum := 0; i := 10; repeat sum := sum + i; i := i + 1; until i > 99; writeln('Сумма двузначных чисел: ', sum); end.

Программа запрашивает у пользователя значение n, а затем вычисляет суммы указанных последовательностей через оператор repeat. Обратите внимание, что каждая последовательность вычисляется в отдельном блоке собственного repeat.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос