Вопрос задан 18.07.2023 в 18:29.
Предмет Информатика.
Спрашивает Ким Денис.
Напишите программу, которая запрашивает пятиразрядное число и выводит число, составленное из цифр
данного числа взятых задом наперёд. Sample Input 1:12345Sample Output 1:54321Sample Input 2:12000Sample Output 2:21БЕЗ ИСПОЛЬЗОВАНИЯ IF И WHILE'Это С++ ес чтоОтветы на вопрос
Отвечает Ермакова Мария.
#include <iostream>
using namespace std;
int main() {
int n, arr[5];
cin>>n;
arr[0]=n/10000; arr[1]=n%10000/1000;
arr[2]=n%1000/100;arr[3]=n%100/10;
arr[4]=n%10;
n=10000*arr[4]+1000*arr[3]+100*arr[2]+10*arr[1]+arr[0];
cout<<n;
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая выполняет указанную задачу без использования операторов if и while:
cpp#include <iostream>
int main() {
int number;
std::cout << "Введите пятиразрядное число: ";
std::cin >> number;
int reversedNumber = (number % 10) * 10000 + ((number / 10) % 10) * 1000 + ((number / 100) % 10) * 100 + ((number / 1000) % 10) * 10 + (number / 10000);
std::cout << "Число, составленное из цифр задом наперёд: " << reversedNumber << std::endl;
return 0;
}
Эта программа считывает пятиразрядное число с помощью std::cin и затем использует арифметические операции для создания числа, состоящего из цифр задом наперёд. Результат выводится на экран с помощью std::cout.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
