Вопрос задан 18.07.2023 в 08:18.
Предмет Информатика.
Спрашивает Галиуллина Камилла.
Написать программу в паскале. Задано четырёхзначное число а. Разбить его на два двухзначных числа
х и у. Определить будет ли сумма цифр числа х равняться сумме цифр числа у. Если да, то вывести фразу а - «счастливое число». Срочно.Ответы на вопрос
Отвечает Глобаж Дмитрий.
program raf105;
var
abcd,ab,cd,a,b,c,d: integer;
begin
write('Введите четырёхзначное число: ');
readln(abcd);
ab:= abcd div 100;
cd:= abcd mod 100;
a:= ab div 10;
b:= ab mod 10;
c:= cd div 10;
d:= cd mod 10;
if a+b = c+d then writeln('Счасливое число');
end.
PascalABC
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль, реализующей указанное требование:
pascalprogram LuckyNumber; var a, x, y, sumX, sumY: integer; begin write('Введите четырёхзначное число: '); readln(a); // Проверка на корректность ввода if (a < 1000) or (a > 9999) then begin writeln('Некорректный ввод. Введите четырёхзначное число.'); exit; end; // Разбиваем число на два двухзначных числа x := a div 100; y := a mod 100; // Вычисляем сумму цифр числа x sumX := x div 10 + x mod 10; // Вычисляем сумму цифр числа y sumY := y div 10 + y mod 10; // Проверяем равенство сумм цифр и выводим результат if sumX = sumY then writeln(a, ' - счастливое число') else writeln(a, ' - несчастливое число'); end.
Программа запрашивает у пользователя четырёхзначное число и проверяет его корректность. Затем число разбивается на два двухзначных числа x и y. Далее вычисляются суммы цифр чисел x и y. Если эти суммы равны, выводится сообщение о том, что число является "счастливым". Если суммы различаются, выводится сообщение о том, что число не является "счастливым".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
