Напистаь программу в турбо паскале Дан массив A размерностью N (размерность вводит пользователь).
Массив заполнен случайными числами от -9 до 28. Написать программу, сортирующую массив по возрастанию.Ответы на вопрос
program delin;
const
nn = 100;// максимальный размер массива
var
i, j, n, t: integer;
a: array[1..nn] of integer;
begin
write('n = ');
read(n);
randomize;
for i := 1 to n do
begin
a[i] := random(38) - 9;
write(a[i], ' ');
end;
writeln;
for i := n - 1 downto 1 do
for j := 1 to i do
if a[j] > a[j + 1] then
begin
t := a[j];
a[j] := a[j + 1];
a[j + 1] := t;
end;
for i := 1 to n do
write(a[i], ' ');
end.
Конечно! Вот пример программы на языке Turbo Pascal, которая сортирует массив A по возрастанию:
pascalprogram СортировкаМассива; const MAX_SIZE = 100; type TArray = array[1..MAX_SIZE] of Integer; var A: TArray; N, i, j, temp: Integer; procedure СортировкаПузырьком(var arr: TArray; size: Integer); var i, j, temp: Integer; begin for i := 1 to size - 1 do begin for j := 1 to size - i do begin if arr[j] > arr[j + 1] then begin temp := arr[j]; arr[j] := arr[j + 1]; arr[j + 1] := temp; end; end; end; end; begin Randomize; Write('Введите размерность массива N: '); Readln(N); // Заполнение массива случайными числами от -9 до 28 for i := 1 to N do A[i] := Random(38) - 9; // Вывод исходного массива Writeln('Исходный массив:'); for i := 1 to N do Write(A[i], ' '); // Сортировка массива СортировкаПузырьком(A, N); // Вывод отсортированного массива Writeln; Writeln('Отсортированный массив:'); for i := 1 to N do Write(A[i], ' '); Readln; end.
Программа сначала запрашивает у пользователя размерность массива N, затем заполняет его случайными числами от -9 до 28. Затем используется алгоритм сортировки пузырьком для сортировки массива по возрастанию. Наконец, исходный и отсортированный массивы выводятся на экран.
Пожалуйста, обратите внимание, что Turbo Pascal - это устаревший язык программирования, и современные компиляторы его не поддерживают. Рекомендуется использовать более современные языки, такие как PascalABC.NET или Free Pascal, для написания программ.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
