Вопрос задан 16.07.2023 в 15:43.
Предмет Информатика.
Спрашивает Котик Никита.
Составьте программу которая Выводит на экран 10 строк таблицы умножения на 2 в Pascal ABC
Ответы на вопрос
Отвечает Пономарь Натали.
Ответ:
program abc;
const N=10;
const C=2;
var a, k:Integer;
I:integer;
begin
A:=0;
for i:=1 to N do begin
A:=A+1;
K:=A*C;
writeln(A,'*',C,'=',K)
End;
End.
Отвечает Сорокин Ден.
Ответ:
var i:integer;
begin
for i:=1 to 10 do writeln(i:2,' * 2 = ',i*2)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на Pascal ABC, которая выводит на экран первые 10 строк таблицы умножения на 2:
pascalprogram MultiplicationTable; var i, result: integer; begin for i := 1 to 10 do begin result := 2 * i; writeln('2 * ', i, ' = ', result); end; end.
Эта программа использует цикл for для итерации от 1 до 10. На каждой итерации она вычисляет результат умножения числа 2 на текущее значение итератора (2 * i) и выводит результат на экран с помощью writeln.
При запуске программы, вы увидите следующий вывод:
2 * 1 = 2 2 * 2 = 4 2 * 3 = 6 2 * 4 = 8 2 * 5 = 10 2 * 6 = 12 2 * 7 = 14 2 * 8 = 16 2 * 9 = 18 2 * 10 = 20
Каждая строка представляет собой результат умножения числа 2 на число от 1 до 10.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
