Вопрос задан 16.07.2023 в 15:00. Предмет Информатика. Спрашивает Самарин Данил.

Информатика. Составьте программу подсчитывающую количество элементов одномерного массива меньше 50

массив задан вводом с клавиатуры. Быстрее пожалуйста!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Слепчевич Вика.

===== PascalABC.NET =====

begin

 var n := ReadInteger('n =');

 var a := ReadArrInteger('Введите элементы массива:', n);

 Println('Элементов, меньших 50:', a.Count(p -> p < 50))

end.

0 0
Отвечает Яцишин Назар.

# python 3.x

k = 0

mas = []

n = int(input('Введите количество элементов массива '))

for i in range(n):

   new_el = float(input())

   mas.append(new_el)

print(mas)

for i in range(len(mas)):

   if mas[i] < 50:

       k += 1

print('Количество элементов массива, которые меньше 50 - ' + str(k))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая подсчитывает количество элементов одномерного массива, которые меньше 50. Программа считывает массив с клавиатуры и затем проходит по всем элементам, подсчитывая количество элементов, удовлетворяющих условию:

python
# Считываем размер массива n = int(input("Введите размер массива: ")) # Создаем пустой массив arr = [] # Считываем элементы массива for i in range(n): num = int(input("Введите элемент массива: ")) arr.append(num) # Инициализируем переменную для подсчета количества элементов, меньших 50 count = 0 # Подсчитываем количество элементов, меньших 50 for num in arr: if num < 50: count += 1 # Выводим результат print("Количество элементов, меньших 50:", count)

Программа сначала считывает размер массива n, затем считывает n элементов массива с помощью цикла for. Затем она проходит по всем элементам массива, сравнивая их с числом 50, и увеличивает счетчик count при каждом элементе, удовлетворяющем условию. Наконец, программа выводит количество элементов, меньших 50.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос