C++ Написать программу которая должна: Выводить на экран все возможные трехзначные числа,
полученные путем перестановки цифр трехзначного числа, вводимого с клавиатуры.Ответы на вопрос
#include <iostream>
using namespace std;
int main()
{
int a;
cin >> a;
int mas[3] = {a / 100, (a % 100) / 10, a % 10};
for (int jjj = 0; jjj < 3; jjj++)
for (int kkk = 0; kkk < 3; kkk++)
for (int lll = 0; lll < 3; lll++)
{
if (jjj != kkk and kkk != lll and lll != jjj)
if (!(jjj == 0 and kkk == 1 and lll == 2))
cout << mas[jjj] << mas[kkk] << mas[lll] << endl;
};
}
Конечно! Вот пример программы на C++, которая выполняет задачу, которую вы описали:
cpp#include <iostream>
#include <algorithm>
#include <vector>
int main() {
int number;
std::cout << "Введите трехзначное число: ";
std::cin >> number;
// Проверяем, что введенное число является трехзначным
if (number < 100 || number > 999) {
std::cout << "Введенное число не является трехзначным.\n";
return 0;
}
std::vector<int> digits;
int temp = number;
// Извлекаем цифры из числа и добавляем их в вектор
while (temp != 0) {
digits.push_back(temp % 10);
temp /= 10;
}
// Генерируем все возможные перестановки цифр и выводим на экран
std::cout << "Все возможные трехзначные числа, полученные путем перестановки цифр:\n";
std::sort(digits.begin(), digits.end());
do {
int permutedNumber = digits[0] * 100 + digits[1] * 10 + digits[2];
if (permutedNumber != number) {
std::cout << permutedNumber << "\n";
}
} while (std::next_permutation(digits.begin(), digits.end()));
return 0;
}
Эта программа запрашивает у пользователя трехзначное число, затем проверяет, является ли число трехзначным. Если число является трехзначным, программа извлекает его цифры и помещает их в вектор. Затем программа генерирует все возможные перестановки цифр и выводит на экран все трехзначные числа, отличные от исходного числа.
Надеюсь, это поможет! Если у вас возникнут дополнительные вопросы, пожалуйста, дайте мне знать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
