Вопрос задан 16.07.2023 в 05:11.
Предмет Информатика.
Спрашивает Смирнов Евгений.
Составьте программу, которая определит сколько раз в тексте встречается заданная буква (на Паскаль)
Ответы на вопрос
Отвечает Анненкова Олеся.
===== PascalABC.NET =====
begin
var s := ReadlnString('Введи текст:');
var c := ReadlnChar('Какую букву ищем?');
Println('Она встретилась', s.Where(p -> p = c).Count, 'раз')
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для определения количества раз, которое заданная буква встречается в тексте, можно написать программу на языке Паскаль. Вот пример программы:
pascalprogram CountLetterOccurrences; const MaxTextLength = 1000; var Text: string; LetterToFind: char; Count: integer; i: integer; begin WriteLn('Введите текст:'); ReadLn(Text); Write('Введите букву для поиска: '); ReadLn(LetterToFind); Count := 0; for i := 1 to Length(Text) do begin if UpCase(Text[i]) = UpCase(LetterToFind) then Inc(Count); end; WriteLn('Буква "', LetterToFind, '" встречается в тексте ', Count, ' раз(а).'); end.
Программа запрашивает у пользователя ввод текста и буквы, которую необходимо найти. Затем она проходит по каждому символу текста, сравнивая его с заданной буквой, учитывая, что поиск буквы должен быть регистронезависимым. Каждый раз, когда символ совпадает с заданной буквой, счетчик увеличивается. В конце программа выводит количество раз, которое буква встречается в тексте.
Похожие вопросы
Информатика 77
Информатика 93
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
