Вопрос задан 16.07.2023 в 04:44. Предмет Информатика. Спрашивает Бояринов Кирилл.

Составьте программу, которая вставляет после буквы "я" слог "мал".(Паскаль)30 баллов

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кот Вадим.

===== PascalABC.NET =====

begin

 var s := ReadlnString;

 s := s.Replace('я', 'ямал');

 Println(s)

end.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Привет! Вот пример программы на языке Pascal, которая вставляет после каждой буквы "я" слог "мал":

pascal
program InsertSyllable; uses crt; var inputString, outputString: string; i: integer; begin // Чтение строки с клавиатуры Write('Введите строку: '); Readln(inputString); // Инициализация выходной строки outputString := ''; // Обработка каждого символа входной строки for i := 1 to Length(inputString) do begin // Добавление текущего символа к выходной строке outputString := outputString + inputString[i]; // Проверка, является ли текущий символ буквой "я" if inputString[i] = 'я' then begin // Вставка слога "мал" после буквы "я" outputString := outputString + 'мал'; end; end; // Вывод результирующей строки Writeln('Результирующая строка: ', outputString); Readln; end.

Программа считывает строку с клавиатуры, затем проходится по каждому символу входной строки и проверяет, является ли текущий символ буквой "я". Если это так, программа вставляет слог "мал" после этой буквы. Результат выводится на экран.

Обратите внимание, что данная программа использует стандартный ввод и вывод, поэтому для ее работы необходимо использовать среду разработки, поддерживающую язык Pascal, например, Free Pascal или Turbo Pascal.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос