C++ Помогите написать программу ! do while для новичков !Дана непустая последовательность целых
чисел, оканчивающаяся отрицательным числом. Необходимо определить, равны ли между собой все элементы последовательности. Отрицательное число членом последовательности не является. Формат выходных данных Выведите «YES», если условие задачи выполняется, и «NO» в противном случае. 1 NO 2 3 4 5 -1Ответы на вопрос
Ответ:
#include <iostream>
using namespace std;
int main () {
int n;
cin >> n;
if (n==0) {
cout << "0 0" << endl << 1 << endl << 1 << endl;
return 0;
}
int mx=0; int mn=10; int mxi=10; int mnk=0; int ind=0;
while (n>0) {
int c=n%10;
n/=10;
if (c>=mx) {
mx=c;
mxi=ind;
}
if (c<mn) {
mn=c;
mnk=1;
} else if (c==mn) ++mnk;
++ind;
}
cout << mx << " " << mn << endl << (ind - mxi) << endl << mnk << endl;
return 0;
}
Объяснение:
Конечно, я могу помочь вам написать программу на C++, которая будет проверять, равны ли все элементы последовательности между собой. Вот пример программы с использованием цикла do-while:
cpp#include <iostream>
using namespace std;
int main() {
int num;
int prevNum = 0; // Переменная для хранения предыдущего числа
bool isEqual = true; // Флаг для определения равенства элементов
do {
cin >> num;
if (prevNum != 0 && prevNum != num) {
isEqual = false;
break;
}
prevNum = num;
} while (num >= 0);
if (isEqual)
cout << "YES" << endl;
else
cout << "NO" << endl;
return 0;
}
Программа считывает числа до тех пор, пока не будет введено отрицательное число. Если текущее число не равно предыдущему числу и предыдущее число не равно 0, то устанавливается флаг isEqual в значение false и цикл прерывается с помощью break. После окончания цикла программа выводит "YES", если все числа равны, и "NO" в противном случае.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
